I have been trying to setup Japanese input on elementary. After many hours of Googling around and installing and uninstalling packages I have made it work with IBus and the Anthy input method. The way I made it work was by installing anthy and Ibus and then running im-config and selecting IBus as the input method. Unfortunately, once I do this I can no longer type at all on Slingshot. Everything except Slingshot seems fine thus far.

I also tried setting things up with fcitx but to get that working I had to remove IBus completely which seemed to eliminate some important packages, some stuff related to System Settings, so I decided not to use that method. Plus fcitx added a new icon on the wingpanel which is quite ugly.

Furthermore, with both IBus and fcitx, mozc didn't work, which works alright on Ubuntu 16.04. This is bad because I prefor mozc to Anthy.

I really want to use Elementary, but I need Japanese input to work and I can not get a satisfactory setup working.

2 Answers 2


I just installed nimf for Korean input and it works like a charm. I don't use Japanese but nimf does support Japanese with anthy so give it a try! First install nimf with sudo apt-get install nimf , then run im-config -n nimf , then reboot. Next, run nimf-settings and set up your hotkey to switch input methods. Reboot again and it should work! Just remember that you might need to install gnome-language-selector ( sudo apt-get install gnome-language-selector ) and switch the Japanese input to nimf since ibus is already installed. Hope it works! :)

  • Thanks! It worked! Unfortunately the support for anthy in nimf is still in alpha stage, so it doesn't work very well. But I will keep using this for now, until I can find a better setup. Commented Sep 21, 2016 at 18:02
  • You should use the new version here: cogniti.github.io/nimf/download
    – JulianLai
    Commented Sep 23, 2016 at 1:47
  • But there still are some problems with it, such as I can't type "人" by typing "jin" with Anthy.
    – JulianLai
    Commented Sep 23, 2016 at 1:49

I was able to get mozc with fcitx working by following this article which is in Japanese, but it is quite easy to follow, specially with the commands and the screenshots.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.