1

Since Loki was released i have problems updating Freya....I get:

Failed to fetch http://archive.canonical.com/dists/freya/partner/binary-amd64/Packages  404  Not Found [IP: 91.189.92.150 80]
Failed to fetch http://archive.canonical.com/dists/freya/partner/binary-i386/Packages  404  Not Found [IP: 91.189.92.150 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
  • Are you usin a x86 or x86-64? From Loki and on, x86 architectures are no more supported. I think you should always use only eOS main repository, not any other one for system updates/upgrades. – Nicola Liguori Sep 21 '16 at 9:19
1

It seems like you messed up your main repository source list /etc/apt/sources.list, you'll have to fix it manually.

Open Scratch with administrator privileges:

pkexec scratch-text-editor

then open /etc/apt/sources.list and change

deb http://archive.canonical.com/ubuntu freya partner
deb-src http://archive.canonical.com/ubuntu freya partner

to

deb http://archive.canonical.com/ubuntu trusty partner
deb-src http://archive.canonical.com/ubuntu trusty partner
-2

Back up your data and make a fresh install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.