1

When freya was released I dualbooted it with Win10. I used this link to add Korean input. Recently I had problems with EFI and booting so I decided to back up all important files and formatted my hard drive and reinstalled with Loki 0.4. Everything has been working great but the instructions in the video don't work anymore. I installed ibus-hangul and dconf editor, added the " [('ibus', 'hangul')] and tried to add Korean input but I can only type in English regardless of what keyboard I'm using. You can probably tell but I'm a noob. Can anyone help me? Thanks!

3

In Loki, nimf is perfect for Korean Input Method. 1) $ sudo apt install nimf 2) $ im-config -n nimf 3) Log out & Log in

Now, you need to go nimf-settings on the wingpanel or run this command in terminal $ nimf-settings

deactivate those two button "anthy" and "sunpinyin" for input method unless you are using Japanese , and Chinese enter image description here

and now you need to set Key combination follow by your behaviour in "libhangul", it is set Hagnul & Hanja key as default key to input Korean & Chinese character for Korean, I usually use Hangul with Shift + Space for Hangul enter image description here

If it doesn't work for you , try to change your keyboard layout to Korean or Korean (101/104)

  • I successfully installed nimf and changed all the settings but nothing happened. my input sources are still English and Korean but Korean keyboard types as English. – E Jeong Sep 20 '16 at 23:46
  • Did you log out & log in ? – Jung-Kyu Park Sep 21 '16 at 0:30
  • Yes, I did.. I did all the settings, logged in and out, but nothing changed. Im curious, what happens when it is successful? is a new input method added automatically? Do i need to edit dconf editor or something else? – E Jeong Sep 21 '16 at 1:35
  • Then, One thing you can do is switching keyboard layout to Korean, Have you tried? – Jung-Kyu Park Sep 21 '16 at 2:36
  • I found the problem! My Korean keyboard was still set to ibus so I switched it to nimf and now it works! 감사합니다~ – E Jeong Sep 21 '16 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.