0

I am trying to disable palm detection or the disabling of the trackpad while using the keyboard. It makes gaming impossible if you use a touchpad to do so. I have found the setting to disable the feature i want removed but i can't seem to make it stay as default.

xinput set-prop 12 299 0 i achieved the setting i would like.

⎡ Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ PS/2 Generic Mouse id=11 [slave pointer (2)] ⎜ ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2)] ⎜ ↳ reserved Pineapple 2.4G Optical Mouse id=14 [slave pointer (2)] ⎣ Virtual core keyboard id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ Power Button id=6 [slave keyboard (3)] ↳ Video Bus id=7 [slave keyboard (3)] ↳ Sleep Button id=8 [slave keyboard (3)] ↳ HP Webcam [2 MP Macro] id=9 [slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)] ↳ HP WMI hotkeys id=13 [slave keyboard (3)] jeff@jeff-HP-EliteBook-8540p:~$ xinput list-props 12 Device 'SynPS/2 Synaptics TouchPad': Device Enabled (142): 1 Coordinate Transformation Matrix (144): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000 libinput Tapping Enabled (293): 0 libinput Tapping Enabled Default (294): 0 libinput Tapping Drag Enabled (295): 1 libinput Tapping Drag Enabled Default (296): 1 libinput Tapping Drag Lock Enabled (297): 0 libinput Tapping Drag Lock Enabled Default (298): 0 libinput Accel Speed (276): 0.000000 libinput Accel Speed Default (277): 0.000000 libinput Natural Scrolling Enabled (281): 0 libinput Natural Scrolling Enabled Default (282): 0 libinput Send Events Modes Available (260): 1, 1 libinput Send Events Mode Enabled (261): 0, 0 libinput Send Events Mode Enabled Default (262): 0, 0 libinput Left Handed Enabled (283): 0 libinput Left Handed Enabled Default (284): 0 libinput Scroll Methods Available (285): 1, 1, 0 libinput Scroll Method Enabled (286): 1, 0, 0 libinput Scroll Method Enabled Default (287): 1, 0, 0 libinput Disable While Typing Enabled (299): 0 libinput Disable While Typing Enabled Default (300): 1 Device Node (263): "/dev/input/event6" Device Product ID (264): 2, 7 libinput Drag Lock Buttons (292): <no items> libinput Horizonal Scroll Enabled (265): 1 As you can see, 299 and 300 are similar but 300 says default. I am getting an error when trying to change 300.

sudo xinput set-prop 12 300 0 X Error of failed request: BadAccess (attempt to access private resource denied) Major opcode of failed request: 131 (XInputExtension) Minor opcode of failed request: 57 () Serial number of failed request: 19 Current serial number in output stream: 20 Is there any way around this or is there anything i can add to set this at startup?

1

I'm not sure why 299 is accepted but 300 isn't, but I think I can answer the second part of your question.

To set the value at startup, try adding the command to ~/.bash_profile (create the file if it doesn't exist). Then, log out and log back in. This file is executed each time you log in. See .bash_profile vs .bashrc for more details.

  • Thanks for getting back to me. That will work perfectly. Much appreciated. – Jeff Sep 21 '16 at 5:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.