0

For some reason clicking of the wingpanel icon's menu items has only once worked for a small amount of time.

They seemed to work for a few minutes so I presumed the problem had been resolved, without me realising it. A while later I tried to click one of the menu items and there was no effect again.

Anyone have any ideas why this might be happening?

closed as off-topic by Daniel Foré, Lewis Goddard Jul 28 '15 at 21:45

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Does this happen all the time or is this only happening as of your last boot? – RolandiXor Jul 27 '15 at 0:50
  • no, it happens all the time – Poohcan Jul 27 '15 at 0:55
  • Are you opening the indicator menu with a left click or right click? There's a known issue where opening an indicator with right click won't let you click on anything afterwords bugs.launchpad.net/wingpanel/+bug/1448450 – Daniel Foré Jul 27 '15 at 15:26
  • Ah, thank you! I must've right clicked the time it worked haha. – Poohcan Jul 27 '15 at 15:29
  • 1
    I'm voting to close this question since it seems OP has verified that it is related to a known bug and there's not really any question to be answered/action to be taken. – Daniel Foré Jul 28 '15 at 17:35
2

You can try running the following command in terminal,my wingpanel was acting weird too.

sudo apt-get install --reinstall wingpanel

You can instead try these commands too, the purge command completely deletes the wingpanel alongwith all its configuration files. So I think you might first want to try the above reinstall command, it worked for me.

sudo apt-get purge wingpanel
sudo apt-get install wingpanel
0

I also had a similar problem, and I think it was a conflict between my usb mouse and my touchpad. I would be using my usb mouse, and all of the sudden your problem would happen to me. I disabled my touchpad in settings (since it doesn't work that well anyway since I spilled coffee on it) and I haven't had the problem since.

Not the answer you're looking for? Browse other questions tagged or ask your own question.