2

I'm running a freshly installed copy of Loki. Updated the system and installed a few basic packages (Firefox etc. - no kernels or anything likely to upset the system), rebooted and found myself locked out.

The password looks to be accepted, however the screen goes blank, and then just dumps me back at the login prompt again. I am able to log in as this user from a bash prompt.

auth.log:

Sep 17 11:25:46 z600 lightdm: pam_unix(lightdm-greeter:session): session closed for user lightdm
Sep 17 11:25:46 z600 lightdm: pam_unix(lightdm:session): session opened for user mike by (uid=0)
Sep 17 11:25:46 z600 systemd-logind[1006]: New session c2 of user mike.
Sep 17 11:25:46 z600 systemd: pam_unix(systemd-user:session): session opened for user mike by (uid=0)
Sep 17 11:25:46 z600 systemd-logind[1006]: Removed session c1.
Sep 17 11:25:46 z600 systemd: pam_unix(systemd-user:session): session closed for user lightdm
Sep 17 11:25:47 z600 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Sep 17 11:25:47 z600 lightdm: PAM adding faulty module: pam_kwallet.so
Sep 17 11:25:47 z600 lightdm: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Sep 17 11:25:47 z600 lightdm: PAM adding faulty module: pam_kwallet5.so
Sep 17 11:25:47 z600 lightdm: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Sep 17 11:25:47 z600 systemd-logind[1006]: New session c3 of user lightdm.
Sep 17 11:25:47 z600 systemd: pam_unix(systemd-user:session): session opened for user lightdm by (uid=0)
Sep 17 11:25:48 z600 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Sep 17 11:25:48 z600 lightdm: PAM adding faulty module: pam_kwallet.so
Sep 17 11:25:48 z600 lightdm: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Sep 17 11:25:48 z600 lightdm: PAM adding faulty module: pam_kwallet5.so
Sep 17 11:25:48 z600 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "mike"

lightdm.log:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.18.2, UID=0 PID=1164
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/40-pantheon-greeter.conf
[+0.00s] DEBUG:   [SeatDefaults] is now called [Seat:*], please update this configuration
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-log-backup.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-greeter-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-guest-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.01s] DEBUG: Monitoring logind for seats
[+0.01s] DEBUG: New seat added from logind: seat0
[+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.01s] DEBUG: Seat seat0: Starting
[+0.01s] DEBUG: Seat seat0: Creating greeter session
[+0.01s] DEBUG: Seat seat0: Creating display server of type x
[+0.01s] DEBUG: Seat seat0: Plymouth is running on VT 1, but this is less than the configured minimum of 7 so not replacing it
[+0.01s] DEBUG: Quitting Plymouth
[+0.40s] DEBUG: Using VT 7
[+0.40s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.40s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.40s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.40s] DEBUG: DisplayServer x-0: Launching X Server
[+0.40s] DEBUG: Launching process 1195: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.40s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.40s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.40s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+1.48s] DEBUG: Loading users from org.freedesktop.Accounts
[+1.48s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+1.79s] DEBUG: Got signal 10 from process 1195
[+1.79s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+1.79s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+1.79s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.79s] DEBUG: Session pid=1247: Started with service 'lightdm-greeter', username 'lightdm'
[+1.80s] DEBUG: Session pid=1247: Authentication complete with return value 0: Success
[+1.80s] DEBUG: Seat seat0: Session authenticated, running command
[+1.80s] DEBUG: Session pid=1247: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/pantheon-greeter
[+1.80s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+1.80s] DEBUG: Session pid=1247: Logging to /var/log/lightdm/seat0-greeter.log
[+1.86s] DEBUG: Activating VT 7
[+1.86s] DEBUG: Activating login1 session c1
[+1.86s] DEBUG: Seat seat0 changes active session to c1
[+1.86s] DEBUG: Session c1 is already active
[+2.23s] DEBUG: Greeter connected version=1.18.2 resettable=false
[+6.87s] DEBUG: Greeter start authentication for mike
[+6.87s] DEBUG: Session pid=1575: Started with service 'lightdm', username 'mike'
[+6.88s] DEBUG: Session pid=1575: Got 1 message(s) from PAM
[+6.88s] DEBUG: Prompt greeter with 1 message(s)
[+2678.91s] DEBUG: Continue authentication
[+2679.11s] DEBUG: Session pid=1575: Authentication complete with return value 0: Success
[+2679.11s] DEBUG: Authenticate result for user mike: Success
[+2679.11s] DEBUG: User mike authorized
[+2679.45s] DEBUG: Greeter requests session pantheon
[+2679.45s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+2679.45s] DEBUG: Session pid=1247: Sending SIGTERM
[+2679.45s] DEBUG: Session pid=1247: Exited with return value 0
[+2679.45s] DEBUG: Seat seat0: Session stopped
[+2679.45s] DEBUG: Seat seat0: Greeter stopped, running session
[+2679.45s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+2679.46s] DEBUG: Session pid=1575: Running command /usr/sbin/lightdm-session gnome-session --session=pantheon
[+2679.46s] DEBUG: Creating shared data directory /var/lib/lightdm-data/mike
[+2679.46s] DEBUG: Session pid=1575: Logging to .xsession-errors
[+2679.54s] DEBUG: Activating VT 7
[+2679.54s] DEBUG: Activating login1 session c2
[+2679.54s] DEBUG: Seat seat0 changes active session to c2
[+2679.54s] DEBUG: Session c2 is already active
[+2679.55s] DEBUG: Session pid=1575: Exited with return value 1
[+2679.55s] DEBUG: Seat seat0: Session stopped
[+2679.55s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+2679.55s] DEBUG: Sending signal 15 to process 1195
[+2680.02s] DEBUG: Process 1195 exited with return value 0
[+2680.02s] DEBUG: DisplayServer x-0: X server stopped
[+2680.02s] DEBUG: Releasing VT 7
[+2680.02s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+2680.02s] DEBUG: Seat seat0: Display server stopped
[+2680.02s] DEBUG: Seat seat0: Active display server stopped, starting greeter
[+2680.02s] DEBUG: Seat seat0: Creating greeter session
[+2680.02s] DEBUG: Seat seat0: Creating display server of type x
[+2680.02s] DEBUG: Using VT 7
[+2680.02s] DEBUG: Seat seat0: Starting local X display on VT 7
[+2680.02s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+2680.02s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+2680.02s] DEBUG: DisplayServer x-0: Launching X Server
[+2680.02s] DEBUG: Launching process 1723: /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+2680.02s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+2680.72s] DEBUG: Got signal 10 from process 1723
[+2680.72s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+2680.72s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+2680.72s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+2680.72s] DEBUG: Session pid=1730: Started with service 'lightdm-greeter', username 'lightdm'
[+2680.73s] DEBUG: Session pid=1730: Authentication complete with return value 0: Success
[+2680.73s] DEBUG: Seat seat0: Session authenticated, running command
[+2680.73s] DEBUG: Session pid=1730: Running command /usr/lib/lightdm/lightdm-greeter-session /usr/sbin/pantheon-greeter
[+2680.73s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+2680.73s] DEBUG: Session pid=1730: Logging to /var/log/lightdm/seat0-greeter.log
[+2680.80s] DEBUG: Activating VT 7
[+2680.80s] DEBUG: Activating login1 session c3
[+2680.80s] DEBUG: Seat seat0 changes active session to c3
[+2680.80s] DEBUG: Session c3 is already active
[+2681.09s] DEBUG: Greeter connected version=1.18.2 resettable=false
[+2681.57s] DEBUG: Greeter start authentication for mike
[+2681.57s] DEBUG: Session pid=1818: Started with service 'lightdm', username 'mike'
[+2681.57s] DEBUG: Session pid=1818: Got 1 message(s) from PAM
[+2681.57s] DEBUG: Prompt greeter with 1 message(s)
[+2712.81s] DEBUG: Session pid=1730: Terminated with signal 1
[+2712.81s] DEBUG: Seat seat0: Session stopped
[+2712.81s] DEBUG: Seat seat0: Stopping; failed to start a greeter
[+2712.81s] DEBUG: Seat seat0: Stopping
[+2712.81s] DEBUG: Seat seat0: Stopping display server
[+2712.81s] DEBUG: Sending signal 15 to process 1723
[+2712.81s] DEBUG: Seat seat0: Stopping session
[+2712.81s] DEBUG: Session pid=1818: Sending SIGTERM
[+2712.82s] DEBUG: Session pid=1818: Terminated with signal 15
[+2712.82s] DEBUG: Session: Failed during authentication
[+2712.82s] DEBUG: Seat seat0: Session stopped
[+2712.84s] DEBUG: Got signal 15 from process 1
[+2712.84s] DEBUG: Caught Terminated signal, shutting down
[+2712.84s] DEBUG: Stopping display manager
[+2713.47s] DEBUG: Process 1723 exited with return value 0
[+2713.47s] DEBUG: DisplayServer x-0: X server stopped
[+2713.47s] DEBUG: Releasing VT 7
[+2713.47s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+2713.47s] DEBUG: Seat seat0: Display server stopped
[+2713.47s] DEBUG: Seat seat0: Stopped
[+2713.47s] DEBUG: Display manager stopped
[+2713.47s] DEBUG: Stopping daemon
[+2713.48s] DEBUG: Exiting with return value 0

Of particular interest is the Sep 17 11:25:48 z600 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "mike" line in auth.log. During installation I checked the Log in automatically option, and then checked the Encrypt home folder option. I am wondering if perhaps it still configured itself to log in automatically, which obviously isn't possible if the home folder is encrypted.

EDIT:

Ran the ecryptfs-mount-private command to check the permissions on .Xauthority and had my passphrase rejected. Entered my old passphrase, and was able to mount and decrypt my home directory. I believe that changing my password in system settings did not change my encryption password?

  • Just ran into this issue and the fix through the Ubuntu forums but it doesn't reliably work. Got the following error when trying the fix: ERROR: Encrypted private directory is not setup properly I am making a final attempt to fix by removing the user and re-adding them followed by a data restore, but this issue MUST be fixed soon, OR, you have to disable password change for Encrypted accounts. This is about the quickest way to get users to abandon you there is. – artphotodude Jan 19 '17 at 23:00
1

Answering my own question here. This looks to be a bug with System Settings.

To fix the issue, I needed to drop into a bash prompt (press Alt + F1 at the login screen), log in as myself. And then did the following:

$ ecryptfs-mount-private 
<old_password>
$ passwd 
Enter existing UNIX password: <current_password>
Enter new UNIX password: <old_password>
Retype new UNIX password: <old_password>

Rebooted and can now log back in again.

The workaround procedure to update your encryption password to match the new login password is:

$ ecryptfs-mount-private 
<old_password>
$ ecryptfs-rewrap-passphrase ~/.ecryptfs/wrapped-passphrase

Strangely I can't reproduce this issue. Changing password with System Settings seems to update the encryption password accordingly now.

EDIT: This seems to be an ongoing bug on Launchpad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.