3

I like vertical two-finger scrolling and enabled it. However, I keep accidentally swiping left and right with two fingers and going back and forward in Chrome, as well as doing weird stuff in other apps. Is there a way to keep vertical two-finger scrolling, but disable to horizontal scrolling?

3

This answer applies only to Loki

Okay, so I might have just proven myself wrong. I did:

sudo apt-get remove xserver-xorg-input-libinput libinput-tools

This removes libinput touchpad driver. Then install synaptics:

sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics

Then restart. In terminal type:

synclient HorizTwoFingerScroll=0

This disables two finger horizontal scroll. Can also add:

synclient PalmDetect=1

for palm detection. Changes do not seem to persist across reboots so you might have to create a custom command on startup for each of these.

I have not tested this extensively, but seems to work so far, use at your own risk. You could always remove the synaptics packages and reinstall the libinput ones if needed.

Jay

  • Thank you. I'd add that sudo apt-get install --reinstall might be a good idea. – mschonaker Jun 28 '17 at 12:58
0

This answer applies only to Loki

I don't think it is possible. It appears that the touchpad driver used is now libinput and according to this post: https://wayland.freedesktop.org/libinput/doc/latest/scrolling.html

It does not differentiate between horizontal and vertical scrolling. Someone can chime in and correct me if i'm wrong. I'd love to have a way to disable it too.

Also mentioned in this post regarding Ubuntu with Gnome: https://ubuntuforums.org/showthread.php?t=2321626

Jay

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.