I can run Opera in my user account but It doesn't work in the guest account.

I first downloaded the .deb package from:


Installed with apt:

sudo apt install opera-stable_40.0.2308.62_i386.deb

Worked well but when someone tried to use the "guest account" it wasn't possible to run Opera.

They could see the icon but nothing happened when clicked on it. Trying to run Opera from terminal in "guest account" gives errors and produce "core".

Unistalled Opera to try another method of installation:

sudo apt purge opera-stable

Then I tried to install Opera with the method of adding the ppa:

sudo add-apt-repository 'deb https://deb.opera.com/opera-stable/ stable non-free'

wget -qO- https://deb.opera.com/archive.key | sudo apt-key add -

sudo apt-get update

sudo apt-get install opera-stable

It hasn't solved the problem.

Guests have still Epiphany and Firefox... (No Opera for them)

Thanks for your help.

  • This doesn't have seem to be updated with more information, and I would think this is an issue with Opera and guest accounts, not elementary specifically.
    – Lewis Goddard
    Sep 25, 2016 at 16:02
  • You are right. The question is too broad. I should rewrite the question. My problem is that everything works fine in "guest account" but opera doesn't work. Thanks for your attention anyway. Sep 25, 2016 at 16:09

1 Answer 1


This can be solved by deleting your program files folder then reinstalling Opera to guarantee that all the program files are perfect and not corrupted. If this does not solve the issue, try renaming profile folders so that Opera creates new ones, and then check if it works fine. After this, you might have to remain with the new profile or try to fix the old profiles, but these two solutions should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.