0

I have a work laptop that had an encrypted partition with Windows 7 and I wanted to dual boot it with Loki. I installed Loki, but during the installation process it told me that I couldn't install it with UEFI without damaging the MBR or something or another, I can't recall. So I went back and partitioned it manually by shrinking the windows partition (within windows) than restarted the installer and made a swap, boot and home partition for Loki and installed Loki. The installation went fine and Loki runs perfectly, but when I boot the computer, I can't choose between Loki and Windows, so I can't boot into Windows anymore, can anyone help me with this?

  • The fact that Loki is warning you about damaging the MBR suggests that Windows 7 was installed in BIOS mode not UEFI, otherwise it would be using GPT. Can you verify that your laptop is actually booting into UEFI and not BIOS? – Mike Wild Sep 26 '16 at 14:44
  • You were right, I checked a secure mode is disabled. – user72805 Sep 28 '16 at 9:01
  • This is not a elementaryOS issue, you need to understand what MBR, GPT, BIOS, EFI/UEFI, etc means first if you are going to dual-boot to keep both OS working – Sebastian Nov 16 '18 at 19:06
0

I'm no expert, but have you tried this? Boot-repair

It worked for me in previous problems i had

  • I tried it, but it didn't work, unfortunetaly – user72805 Sep 29 '16 at 12:55
0

I had boot problems too, but in my case I could only boot Windows. I recommed you to try rEFInd. Once installed, it should recognize all your OSes and let you choose which one to boot.

  • This didn't work for me either, because I found out I don't have a EFI-bootpartition. – user72805 Sep 29 '16 at 12:57
  • You could try this in a terminal: "sudo update-grub" and see if that fixes the problem. When executing this command, you're telling grub to rescan your partitions in search of any OSes. – derkomai Sep 29 '16 at 15:25
0

First of all, you should try to unhide your grub menu.

  1. Open /etc/default/grub as sudo
  2. Comment the line GRUB_HIDDEN_TIMEOUT=0 (put a # in the beginning)
  3. Set GRUB_TIMEOUT_STYLE=menu (instead of hidden)
  4. Open terminal and do: sudo update-grub
  5. Reboot and you should see Grub menu. Select Windows and see if it boots.

If it doesn't boot, you should repair your Windows MBR. There is a comprehensive guide here: https://neosmart.net/wiki/fix-uefi-boot/

And after repairing your Windows MBR, you need Boot-repair to get Elementary to boot and then again, you need to unhide your grub menu with the steps i described above.

This happens to me everytime i install Elementary in a Windows 10 UEFI dual-boot. I have to repair Windows MBR, run boot-repair and unhide Grub from Elementary. It may seem boring and time-consuming, but you can do it under 20 minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.