0

apturl is installed.

When clicking such a link (like on https://apps.ubuntu.com) in Epiphany and Firefox nothing happens.

Even tried it Palemoon, with the same result. In both Firefox and Palemoon I can see apt associated with aprurl:

enter image description here

enter image description here

When clicking it in Chrome or Chromium this happens:

enter image description here

But when trying to set apturl as default aplication following this answer, there is no apt entry in gconf-editor

The command xdg-mime default apturl.desktop x-scheme-handler/apt gives no errors, and apturl seems the default application for apt links, because:

~$ xdg-mime query default x-scheme-handler/apt
apturl.desktop

But then the same happens.

What I'm asking is: a way to make apturl open those links it is supposed open (like it does in my other Linux installations) or a reason why it doesn't work in elementary Loki (while it worked in Freya).

  • 1
    What are you actually asking here? It is not clear what the question is. – Mike Wild Sep 26 '16 at 14:39
  • @MikeWild - I thought that when I'm saying something doesn't work (like 'aptrurl doesn't wotk in elementary Loki', as the title says) it is clear that I ask for a way to make that work. Added a few lines into the question body. – user170 Sep 27 '16 at 12:32
2
+25

Here's a quicker route for making the affiliation:

sed -i '$a xdg-mime default org.pantheon.appcenter.desktop x-scheme-handler/apt' ~/.local/share/applications/mimeapps.list

This appends x-scheme-handler/apt=org.pantheon.appcenter.desktop to your list of custom mime types

My install of apturl had all sorts of issues and in the end, it never even ran apt:// successfully. AppCenter should be natively processing inbound links anyway, as they previously went to Ubuntu's software center. I filed a bug report here.

  • the fact that apturl doesn't work anymore is also a bug I guess. This is not an answer to the question but if it works I'll grant the bounty. – user170 Sep 29 '16 at 6:44
  • that line run in terminal should automatically open apt links like this (apps.ubuntu.com/cat/applications/deluge) in AppCenter I guess. I set Firefox to 'always ask' for apt, have associated then with /usr/bin/appcenter, but no, it doesn't open yet – user170 Sep 29 '16 at 6:57
1

In my view, the apturl should is interconnected with AppCenter, but the store does not support, I hope you soon.

You can use Gnome Software is the new store Ubuntu 16.04, with it is possible to use apturl.

See how to install

  • Your text is not clear. apt-urls are present on many websites, like this one. And I don't want to use something different. Do you mean this tool is not supposed to work in 16.04? – user170 Sep 16 '16 at 15:31
  • The apt-urls do not work in Loki, because this functionality is not present (enabled) in the store the ElementaryOS. In Ubuntu 16.04, this option works, because this enabled with your store. – sjodiel Sep 16 '16 at 16:13
  • Apt-url-links are links that are either present or absent, they are not enabled or disabled. Ubuntu repos are enabled in Loki. Programs from Ubuntu repos and other enabled repos can be installed through different methods: apt program in terminal, synaptic, the apt://url links that I'm talking about and programs like AppCenter. For example Gimp program can be installed in these ways, but not through the apt-link here, at least no on my system. – user170 Sep 17 '16 at 11:25
  • Hi. In eOs, I install programs via .deb, via terminal, via synaptic, and via apt://url. See the image i.stack.imgur.com/gcX0Q.png – sjodiel Sep 17 '16 at 15:54
  • glad to hear that. can you help me on why that doesn't work for me as indicated in my question? – user170 Sep 17 '16 at 20:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.