I have a Dell XPS L502X Nvidia and Intel video cards.

I'm not sure if this a Nvidia/Nouveau issue but Slingshot menu always has a delay. Usually after the second try it works fairly fast again, but if I click it again after a few minutes the delay comes back.

I had Nvidia-361 installed the issue was there. I did a clean install of Loki but this time with Nouveau drivers and have the same issue.

Is anyone going through this, and if so is there a solution?

  • I got the same problem in freya, was hoping it will get solved in loki but seems like not :(
    – Alexandr
    Commented Sep 15, 2016 at 23:29
  • I've also noticed that slingshot is 1. noticeably slower than other launchers, 2. inconsistent in its speed (sometimes it gets particularly slow). I believe it's just the app, not your drivers.
    – Gabriel
    Commented Sep 16, 2016 at 0:22
  • I was afraid of that Commented Sep 16, 2016 at 3:56
  • Definitely not just the drivers. Same problem here on a Dell Inspiron 15 5559 with Intel Skylake i7 / AMD Radeon R5 M335 graphics
    – deesnook
    Commented Sep 18, 2016 at 22:55
  • 2
    In Launchpad. See here: launchpad.net/elementary there is a tab for bugs. I just filed our problem there: bugs.launchpad.net/slingshot/+bug/1625775
    – deesnook
    Commented Sep 20, 2016 at 19:05

2 Answers 2


I finally found a solution to this.

Open terminal and type

cd /usr/bin

sudo mv zeitgeist-daemon zeitgeist-daemon.bak

sudo reboot

I noticed the Zeitgeist-daemon was affecting my Slingshot. On the downside if you have to use Security & Privacy on Switchboard it wont open. You would need to launch zeitgeist-daemon.bak first and then try to open it.

By disabling zeitgeist-daemon, the first time you open Slingshot will fill a bit slow but then after that it will always work fine.


I found an alternative solution.

There is a Slingshot Launcher fork call Panther Launcher. It looks and works exactly the same.

It is faster and it does not depend on Gala or Granite.


Download the Ubuntu 64 bit version and install it.

Then open System Settings - Desktop - Hot Corners

Select the top left corner and choose Execute Custom Command and set it to


Then go back to System Settings - Keyboard - Custom and add a new shortcut.

The first time you launch Panther might freeze but try again and it will work just fine after.

If you want to customize the amount of columns, icon size, etc. Open Dconf-editor and go to


Once you finish customizing you need to kill Panthern and launch it again.

killall panther_launcher

So far this is the best solution for me, I don't know why but Slingshot it is very laggy and I would love to use it by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.