0

I have a System 76 laptop with nvidia dedicated graphics and am having trouble with the brightness adjustment controls in Pantheon. I have installed the system76-driver-nvidia from their ppa.

I have tried to use the inotify/xbacklight based solution detailed here

http://sub-pop.net/post/fedora-23-on-system76-oryx-pro/

(which basically uses information from /proc and xbacklight to adjust the brightness) and it doesn't have any effect nor any helpful errors in the logs. This is how I get the display to work properly in GNOME3 on arch.

I am hoping that since one of the Elementary OS devs works at system 76 there is a solution that I just haven't found. Thank you in advance for any help that you can give!

  • It I add the backlight script to the startup applications then it seems to work. Though I am upset and cant figure out why it wont run under systemd – David M. Sep 15 '16 at 3:54
  • I will talk to hardware engineering today and see if they have any ideas. You can also open a ticket at system76.com with the same information posted here and see if the support team has any ideas. :) – Cassidy James Sep 15 '16 at 17:27
  • I didn't think I was supposed to open tickets if I am not running the stock ubuntu. Will do. – David M. Sep 15 '16 at 18:35
-1

Slight edits to the original posts, got it to work systemd.

http://www.pynut.com/?p=386

  • Would you please expand on your answer in case the link goes down in the future? – wolf Sep 28 '16 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.