3

In the software center you get Filezilla 3.7.3. (It was the same on Linux Mint, I used before). But unfortunately I used a newer version for years on Mageia before. Importing the server-bookmarks now is possible but they can´t connect as the password is stored encrypted.

So I want to install a newer version of Filezilla, but I don´t succeed. On Linux Mint it works with this ppa:

sudo add-apt-repository ppa:n-muench/programs-ppa

But not on Elementary - do you have a hint for me? Thanks a lot!

  • I get the message, that Filezilla is up-to-date! I have version 3.7.3 - I want at least 3.18! How do I get a newer version? – brandy Sep 14 '16 at 10:55
  • What version of elementary are you running? Freya or Loki? – Andrés Buitrago Sep 15 '16 at 12:33
2

Loki removed the ability to install from PPAs out-of-the-box. You can restore this functionality by installing the software-properties-common package and then adding the PPA as before.

sudo apt install software-properties-common
sudo add-apt-repository ppa:n-muench/programs-ppa
sudo apt update
sudo apt install filezilla
  • Non-terminal answers are preferred - if anyone knows how to achieve this using App Center (something like this) then that would be the better answer. – Mike Wild Sep 14 '16 at 8:24
1

The current version on actual elementary's release (0.4 Loki) is 3.15.0.2 so this might indicate that you are still running Freya.

What's the issue here? Freya is based on Ubuntu 14.04 which was released more than two years ago.

The solution: Either upgrade to elementary OS 0.4 Loki (which has the AppCenter. A non terminal solution for app installing and the latest stable version available 3.15.0.2) or use the Terminal in Freya with the previous answer to install a later version of Filezilla from a PPA.

  • Ok, there is a new release - maybe I update! But the ppa from the post above didn´t work - I get the message, that Filezilla is up-to-date - and that´s 7.3.7! – brandy Sep 15 '16 at 13:27
  • @brandy it (the PPA) won't work on 14.04 if the version of FileZilla you are looking for was not compiled for 14.04 in that PPA. I suggest migrating to Loki. – RolandiXor Sep 15 '16 at 18:04
  • But when I read the recent reviews about Loki, I don´t know If i should change to Loki... – brandy Sep 16 '16 at 8:06
  • Loki is okay - but I haven´t done so much work in the Terminal in any previous used Linux-distribution... – brandy Sep 19 '16 at 5:59
0

A graphical solution:

  1. Click "Applications" in the upper-left corner and search for Software & Updates
  2. Tab over to "Other Software" and add your PPA address there.
  3. Update as you would in Linux Mint (sudo apt-get update && sudo apt-get upgrade). I imagine AppCenter should search for update the same way, but I haven't tried it myself.

Other Software

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.