I cannot search in application menu launcher (hmm, i think it's slingshot). I can open the menu and launch the applications from menu. But, I really cannot search in the app-menu-launcher. I don't know what was wrong.

Thank you.


  • 1
    I have same problem please help
    – James S
    Commented Sep 14, 2016 at 22:18

3 Answers 3


I've found that this is caused by ibus-daemon program. If you have ibus running on startup, remove it or add a startup item to kill the ibus-daemon. You should be able to search in Slingshot launcher.

  • 1
    it solved perfect. really appreciated. kudos!
    – La Min Ko
    Commented Dec 6, 2016 at 16:43
  • Please include instructions for how to do this for less experienced users.
    – RolandiXor
    Commented Dec 22, 2017 at 3:04
  • @RolandiXor adding a command killall ibus-daemon will do the job
    – Anwar
    Commented Dec 23, 2017 at 5:39

After having temporarily solved following your suggestion, that is stopping the ibus-daemon service, I have tried to reset it's configuration (ibus -reset-config), and now the problem is disappeared, also after having rebooted, with the ibus daemon active.


Same Problem. Different cause.

Problem: The search in "Applications" can be disabled when installing Windows programs via Wine. A 120 character directory was generated including spaces during the install that disabled the search function. It was traced to this directory ~/.local/share/applications/wine/Programs$

Not good.

Solution: Removed program,*.desktop files, and dead directory name w/spaces. Applications search feature works as designed. Maybe a function tree search code change in Applications can fix this problem. If I can break it, I guarentee someone else will too.

Lesson: For Wine,known Gold/Platinum programs only. If need to use a windows program. Use Windows.

Note: If your Windows programs run in wine, make sure you check in the wine programs files and ensure the directory names do not contain spaces. Remove them if you want to search Applications.

Not the answer you're looking for? Browse other questions tagged or ask your own question.