After a fresh install of Loki, I go to point Noise to my existing music folder but I can't select the folder at all. Same with import, selecting a folder (or audio file for that matter) does not seem to work for me. I remember in Freya selecting a folder and hitting "enter" or something would immediately begin import.

Anything I might be missing? Thanks in advance!

  • Same problem here! And I even couldn't change the music folder location. How did you confirm your selection of the folder? I just move the desired folder, but nowhere i can confirm to execute the action. Seems there is a button of confirmation missed. Actually the same problem is it when you trying to import music and videos(into Videos). I am not sure should I to execute the action by hot key or anyway else. Is it a different way of operating it? I feel very weird of this have no idea what is the right way of operation.
    – ultra
    Sep 19, 2016 at 13:05

2 Answers 2


I finally managed to figure it out. For anyone else who has been having trouble importing music into Noise, follow these steps:

  • Open Noise settings
  • Preferences
  • Music Folder Location: (Default: Music)

Then change the default location and it will begin loading from what was previously selected.

In my case, I had all my music in the music folder which was not being imported. When I went to change this setting I flipped the option to Downloads and then it immediately started importing the music from the Music folder.

Hope this helps anyone else having this issue!


You can delete the entire database in ~/.local/share/noise/

Noise will then re-scan everything. This is not an ideal solution, an option would be great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.