1

I'm new to eOS. Today I made my fresh install on my computer. I just installed latest release (Loki) and after a installing a few packages it happened this:

What?

As you can see, there is a desktop window inside desktop (?). The only issue here is I cant drag icons freely on desktop screen, icons are stuck inside that window. Among few things i did before, I just installed elementary-tweaks and some other programs (I was wondering if it has to do with installing Nemo fileroller. I can interact with this window and it opens directly that file manager when click on a folder). Anyone else with this issue? Any fix or workaround? Thanks!

2

This worked with Luna, you can try and see if it still works (taken from this answer):

If you install Nemo you might end up with an "un-closable" window in your desktop that you can't close (see here).

To fix this you need to add --no-desktop to the nemo.desktop file so it reads:

Exec=nemo --no-desktop %U
  • Mmm... did that, saved nemo.desktop and reboot. Nothing changed. I'll be checking the answer you linked :) – Carlos R. Sep 13 '16 at 5:30
  • Kind of get it, after reading a while of those threads I realized is because Nemo's behavior is not compatible with pantheon or something. Also, by default eOS desktop don't show icons. For the moment, only thing I do is to minimize the annoying window (right click > minimize). I wonder if instead of getting rid of that window, we keep it maximized, filling screen behind menus... which would be a workaround, I guess. – Carlos R. Sep 13 '16 at 8:52
1

For the record:

The command nemo --no-desktop seems to work on some configs, but not always. A bit of research and found that

 gsettings set org.nemo.desktop show-desktop-icons false

did the trick for me (link). As the problem is solved for me, I still wish to know if is possible to make nemo appear fullscreen. When installed on Ubuntu there is no issue with this window >:( (it is maybe configured correctly to work on some distros?)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.