5

I´ve just installed elementary OS Loki, and downloaded and installed Google Chrome from their website. When I turn off my computer, and restart, Google Chrome don't remember any password, not even the sync one. So I have to manually reenter my account. How I can fix it?

  • Note - This is not an answer. Since I cannot comment, I am sharing some general suggestions and asking some questions. > ...and downloaded and installed Google Chrome from their website. You mean, installed .deb from Google's website or installed Chromium from the new app store? > Google Chrome don't remember any password, not even the sync one. So I have to manually reenter my account. Are you being logged out of Google Chrome on each restart or Are you being asked for Keyring password each time? Please provide more details. Additionally, have you turned on "Log in Automatically"? How did you – Paritosh Sep 12 '16 at 21:24
  • cont... "How did you install Google Chrome (gedbi or apt-get install)? Were there any errors when installing Google Chrome the first time? A small, rather alternative (and not a solution) is to uninstall Google Chrome completely and install Chromium from app store." – Lewis Goddard Sep 13 '16 at 18:12
  • I installed Chrome downloading a .deb and I also did it with GDebi. It always asks me for the keyring password, for the password of the Chrome User and the passwords which normally remembers like user and password of gmail, facebook, twitter.... And all of them had turned on "Log in Automatically" or "Remember me". – Víctor Sep 17 '16 at 21:20
  • I have exactly the same problem. Tried purging chrome, deleting config directory, unlinking my account and re-syncing, but no luck so far. – derkomai Sep 22 '16 at 7:46
  • It's seems to be a problem with Chrome. I just uninstalled elementary and installed Ubuntu MATE and the problem with Chrome persists. – Víctor Sep 23 '16 at 0:40
1

Setting this keyring to blank should let it do its thing without bothering you. If you have already set it up, trash your keyring and restart Chrome to receive the fresh prompt, where you can set it to not use a password.

Check the following locations for the keychain (remember to save a copy as backup first):

  • ~/.gnome2/keyrings/default.keyring
  • ~/.local/share/keyrings/*

More elaboration and links at my Unix SE post.

2

I was having a problem once where I changed my user account password and then my key-chain popped up when I logged into the system, or launched chrome. You just need to put in your original key-chain password if this is what is happening to you. If it's not then you could always manually go in and change your key-chain password so that it automatically saves your data.

Another, easier, way around this is to log into google chrome using your google account and download lastpass password manager and that can act as your online key-chain.

1

It's because you have auto login set. If you disable auto login Chrome will not ask each time. It's a security "feature".

  • 1
    That's not technically true, to my knowledge this is not a feature as it does not affect me. However, it is a bug where the keyring is not unlocked at login when you auto-login. Chrome just happens to be an app that requires the keyring be unlocked. – Lewis Goddard Nov 23 '16 at 11:21
  • Is there a way then to keep auto-login and not being asked every time? – Philip Claren Jan 16 '17 at 13:41
  • I solved this by disabling auto login, disabling my Google account in chrome and then re-enabling. – Pretzel Jones Jan 16 '17 at 23:46
-1

This has to do with online accounts in System Settings. In Ubuntu this is easy to fix. Just add Google as an online account in "System settings -> Online accounts" and the sync problem (login every reboot) will go away.

However in elementary OS, you cannot add a Google account in Online accounts (hopefully, at least not yet) in System Settings. So for now there seems to be no fix for this (or if it is possible to add the same Online accounts in Ubuntu to elementary OS then there's a chance.)

Also one of the reasons this is happening is if you have auto login enabled when logging in to your PC. Disabling it (entering your password every time you login) will solve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.