2

I've compiled vim from source following these instructions (except I did not specify a prefix to install it to the default location viz. /usr/local) and also ran the following:

sudo update-alternatives --install /usr/bin/editor editor /usr/local/bin/gvim 1
sudo update-alternatives --set editor /usr/local/bin/gvim

and then confirmed that it's been set as the default using

sudo update-alternatives --config editor

However, I still don't get the option to select gvim as a text editor in Settings > Applications > Default.

3

You can select it on Settings>Applications on the Default tab from the "Text Editor" menu.

enter image description here

2

The easiest way to change the default application for a file type is to right-click on any of such file type > Properties > Open with.

Properties

If you click on "Other Application", you can "Set as default" from the list of Recommended Applications.

Recommended

Now if your issue is that gvim isn't even showing in these menus, try purging your old install and trying again with: sudo apt install vim-gnome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.