17

I recently installed elementary OS 0.4 Loki.

The language of my OS is English but I use the Spanish (from Spain) keyboard.

I've been using elementary OS since Luna and this hasn't happened to me before.

When I try to take a Screenshot using the usual/standard key on the keyboard, I get nothing. No sound, no screenshot, nothing.

I check the Keyboard Settings and saw this:

screenshot of my keyboard settings shortcuts regarding screenshot Prior to this I haven't done a single edit to my Keyboard Settings, yet Take a Screenshot appears to be Disabled. If I try to set the Print key nothings happens, it just says disabled and stays that way.

I tried to put a random combination (Ctrl+P) but it did nothing, all I hear is a faint sound of warning and it doesn't take the picture.

The app itself does works normally, although I miss the "camera-shutter-sound" it used to make.

11

Actually this issue touches two different bugs in Loki:

  1. Printscreen "PrtScn" button doesn't actually take a screenshot
  2. Custom keyboard shortcuts not working, loki fresh install
  • 1
    As a workaround in the meantime you can open the applications menu, type "screenshot-tool -r", then press enter. – Seth Jan 16 '17 at 23:32
  • To add to Seth's comment: screenshot-tool -r takes a screenshot of a region, saving to a file, and screenshot-tool -rc saves it to the clipboard. Further options are listed by screenshot-tool --help. – waldyrious Jul 23 '17 at 15:35
5

This is a bug, you can check it out here https://bugs.launchpad.net/elementaryos/+bug/1622298

0

I've also run into this problem, which I think has two parts.

  1. It appears that the PrintSc button itself is not mapped. I have successfully mapped Ctrl+0 to work with gnome-screenshot, but when I tried to map PrintSc to the command, it didn't work.

  2. It appears that the native Print Screen command doesn't work. I thought that if I could map Ctrl+0 to the gnome-screenshot command, then it would work, but when I tried to do this through the keyboard shortcuts menu, it did not work.

Not the answer you're looking for? Browse other questions tagged or ask your own question.