3

Hi everyone I just installed Loki and I'm having trouble with my touchpad sensibility. It's too high!! I read about changing a property called Synapitics Finger but I couldn't find it !!! Here's the output when I run xinput --watch-props 13 :

franciscone-Inspiron-5458:~$ xinput --watch-props 13

Device 'SynPS/2 Synaptics TouchPad': Device Enabled (139): 1 Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000

libinput Tapping Enabled (275): 1
libinput Tapping Enabled Default (276): 0
libinput Tapping Drag Enabled (277):    1
libinput Tapping Drag Enabled Default (278):    1
libinput Tapping Drag Lock Enabled (279):   0
libinput Tapping Drag Lock Enabled Default (280):   0
libinput Accel Speed (281): 0.000000
libinput Accel Speed Default (282): 0.000000
libinput Natural Scrolling Enabled (283):   1
libinput Natural Scrolling Enabled Default (284):   0
libinput Send Events Modes Available (259): 1, 1
libinput Send Events Mode Enabled (260):    0, 0
libinput Send Events Mode Enabled Default (261):    0, 0
libinput Left Handed Enabled (285): 0
libinput Left Handed Enabled Default (286): 0
libinput Scroll Methods Available (287):    1, 1, 0
libinput Scroll Method Enabled (288):   1, 0, 0
libinput Scroll Method Enabled Default (289):   1, 0, 0
libinput Click Methods Available (290): 1, 1
libinput Click Method Enabled (291):    1, 0
libinput Click Method Enabled Default (292):    1, 0
libinput Disable While Typing Enabled (293):    1
libinput Disable While Typing Enabled Default (294):    1
Device Node (262):  "/dev/input/event6"
Device Product ID (263):    2, 7
libinput Drag Lock Buttons (295):   <no items>
libinput Horizonal Scroll Enabled (264):    1
3

I just posted a solution for another question that might help you for this as well on:

Way to enable vertical two-finger scrolling, but not horizontal?

I removed the libinput drivers for the touchpad and installed the synaptic drivers instead I did:

sudo apt-get remove xserver-xorg-input-libinput libinput-tools

This removes libinput touchpad driver. Then install synaptics:

sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics

Then restart.

This also allowed me to change Two Finger Horizontal scrolling and add palm detection (see above link) and also made the touchpad less sensitive.

I have not tested this extensively, but seems to work so far, use at your own risk. You could always remove the synaptics packages and reinstall the libinput ones if needed.

Jay

2

I've had luck by installing dconf-editor with: sudo apt-get install dconf-tools

Open dcong-editor and navigate to org > gnome > desktop > peripherals > touchpad to change the speed manually to something negative.

2

You can adjust the speed sensitivity by playing with the numbers for libinput Accel Speed. It will accept anything from -1 to 1.

For instance, you can try:

xinput --set-prop "SynPS/2 Synaptics TouchPad" "libinput Accel Speed" -0.5

You may need to set this value automatically every time your computer starts.

To do that, you'll need to save an executable .sh file in your startup applications which contains something like this:

#!/bin/bash

# Trackpad Accel Speed was 0. Accepts values between -1 and 1.
xinput --set-prop "SynPS/2 Synaptics TouchPad" "libinput Accel Speed" -0.5

exit
0

I just posted a solution for another question that might help you for this as well on:

Way to enable vertical two-finger scrolling, but not horizontal?

I removed the libinput drivers for the touchpad and installed the synaptic drivers instead I did:

sudo apt-get remove xserver-xorg-input-libinput libinput-tools

This removes libinput touchpad driver. Then install synaptics:

sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics

Then restart.

This also allowed me to change Two Finger Horizontal scrolling and add palm detection (see above link) and also made the touchpad less sensitive.

I have not tested this extensively, but seems to work so far, use at your own risk. >You could always remove the synaptics packages and reinstall the libinput ones if needed.

Jay

It works for me! Thx!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.