I don't know where to ask this, so I'm asking it here.
Situation: dynamic IPv6 addresses from ISP, wired modem, home computer.
Symptoms: many web pages don't load; no software is shown in AppCenter except what is installed; sudo apt-get update works extremely slow (it doesn't finish updating after 1 and a half hours). Behaviour is similar in Ubuntu 16.04 and Linux Mint 18 KDE.
In Freya ipv6 is ignored by default and I don't have any connection problems. In Loki I'm connecting with ipv6 by default and I'm having the problems described above.
Changing Network > Advance Settings > IPv6 Settings > Method: Ignore, leaving IPv4 Settings > Method: Automatic (PPPoE) has no effect. I've tried disabling ipv6 by editing /etc/sysctl.conf; /etc/default/grub; /etc/gai.conf; or blacklisting ipv6 in /etc/modprobe.d/blacklist.conf. It didn't work. I've also tried sudo apt-get -o Acquire::ForceIPv4=true update without success.

1 Answer 1


I solved it. IPv6 doesn't need to be stopped. I needed to add the line "mtu=1492" in the file /etc/NetworkManager/system-connections/Connection name like this:


After making the DSL connection at first, of course. Then reboot and updates are working, and software is visible in AppCenter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.