How can I disable tap-to-click in the greeter/login screen of elementaryOS?

I know that I can disable tap-to-click on a desktop of a user in the settings dialogue of mouse and touchpad. In the command line this is done using e.g. gsettings.

However, as a user tap-to-click is disabled for my users and I can check that with:

gsettings get org.gnome.settings-daemon.peripherals.touchpad tap-to-click

But I fail doing it for the greeter having an annoying behaviour of the UI when typing in passwords.

I found that my question here duplicates this launchpad bug.. However, may be someone finds a workaround faster than me ;) However, I upgraded to Loki, but am still somehow interested in finding how to change the tapping behaviour in the greeter.

1 Answer 1


There is a palm detection method
Try this: https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Disable_touchpad_while_typing

  • I once saw this tip. However, recently I upgraded to Loki. There the problem does not exist anymore. Why? I do not know: In the packages (now Loki) I search, there is no 'xf86-input-synaptics'. Therefore I do not find '70-synaptics.conf' in '/usr/share/X11/xorg.conf.d/'. And '/etc/X11/xorg.conf.d/' does not exist - only '/etc/X11/Xsession.d'. Sep 18, 2016 at 13:03
  • You can create '/usr/share/X11/xorg.conf.d/', then 50-synaptics.conf
    – winger
    Sep 19, 2016 at 15:36
  • Actually it doen't matter how you name config file because the whole 'xorg.conf.d' directory was created for these 'somename.conf' files just to split for the sake of simplicity '/etc/X11/xorg.conf' which is for all X server settings.
    – winger
    Sep 19, 2016 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.