I got a red circle with a crossed red line instead of Dropbox icon.

6 Answers 6


The correct instructions to run are :


it worked for me !

The -i option is only necessary the first time to install the daemon, but if you've installed dropbox with the current user, that's already done.

  • this one helped me, is there any way to make it permanent ? currently am running this command during startup, also its working for other apps too Commented Oct 25, 2016 at 6:42
  • 3
    Yes, just add another entry in Parameters => Applications then Startup tab ... that's what I did and I don't have to type it anymore. And of course, you will have to disable the existing dropbox entry. Commented Dec 11, 2016 at 1:02

Dropbox does not recognize Elementary's desktop interface. Therefore, it does not know which icon set to use.

This script has been designed for Elementary OS and I really can recommend it: https://github.com/zant95/elementary-dropbox

Alternatively, you can try running the following commands to use Unity's icon set.

dropbox stop

dropbox start -i

If this works, you can edit the desktop file located in /usr/share/applications. Open the file with your favourite text editor and change the line Exec=dropbox start -i to Exec=DROPBOX_USE_LIBAPPINDICATOR=1 XDG_CURRENT_DESKTOP=Unity dropbox start -i

Got it from here: https://unix.stackexchange.com/questions/198977/dropbox-tray-icon-doesnt-show-up-in-elementary-os-luna-freya

sudo nano /usr/share/applications/dropbox.desktop

then replace the exec line to

Exec=env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE='' dropbox start

dropbox stop

dropbox start -i
  • Thank you for giving advice how to find and edit the desktop launcher. This was the missing bit in the first answer. Commented Feb 10, 2018 at 18:46

The simplest solution is to add the following two lines in /usr/bin/dropbox, just after import os:


Just found out that the default dropbox script simply copies


to $HOME/.config/autostart/dropbox.desktop

So, instead of using the scripts suggested in the answer, simply edit /usr/share/applications/dropbox.desktop

Change the exec line to:

Exec=env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE='' dropbox start -i

And then overwrite the autostart file:

cp /usr/share/applications/dropbox.desktop $HOME/.config/autostart/dropbox.desktop

Now, logout and login again and the problem is solved, forever. ;)

  • If dropbox updates it might overwrite usr/share/applications/dropbox.desktop back to it's default value.
    – Jeroen
    Commented Mar 12, 2018 at 14:52
  • I'll be sure to report the upgrade status back here after dropbox upgrades. :)
    – Erwin Zoer
    Commented Mar 13, 2018 at 16:25

env XDG_CURRENT_DESKTOP=Unity QT_STYLE_OVERRIDE='' dropbox start Is the only one that worked but has odd behaviour in Start Applications. As you can see the env line is shown, then once it successfully runs with correct icon it instantiates a new startup item which even though is disabled for some reason or other wants to run resulting in errant red icon in tray. Env command before run After run Env command Next run Env command with errant tray icon

  • The simplest solution from Waldy above seems to work keep the Dropbox startup icon and do away with the env call in startup.
    – Alistair
    Commented Jun 4, 2018 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.