8
  1. AppCenter is empty, only the installed software is shown.
  2. I can't add repositories. I get the message 'sudo: add-apt-repository: command not found'.
  3. sudo apt install software-properties-common doesn't work either. I get the message 'E: Unable to locate package software-properties-common'
6
  • i have the sames problems... i cant install anything and i cant add repos... what i do a operating system if i cant install my apps? no gparted no clementine no steam no chromium no easytag no no no no... the command sudo apt-get update dont solve the problem mate...! now i see here blog.elementary.io/post/145881464631/loki-beta to say no unsafe software source... someone else will decide for me what is safe and what is not..? reminds me microsoft and osx
    – Arktika 13
    Commented Sep 10, 2016 at 13:20
  • Do you have ipv6? It might be the problem. Commented Sep 10, 2016 at 14:42
  • 1
    Related: elementaryos.stackexchange.com/questions/7542/…
    – Lewis Goddard
    Commented Sep 10, 2016 at 19:03
  • I tried Ubuntu 16.04 and Linux Mint 18 KDE and the symptoms are the same (some websites don't load, update doens't work). I'm almost certain that it's a network manager and/or ipv6 problem on a pppoe (dsl) connection. In Freya ipv6 is ignored by default. In Loki I'm connecting with ipv6 by default, and I wasn't able to disable it yet with several methods found over the internet. Commented Sep 11, 2016 at 9:24
  • So I solved it. I needed to add the line "mtu=1492" in the file /etc/NetworkManager/system-connections/*Connection name* like this: [ppp] lcp-echo-failure=5 lcp-echo-interval=30 mtu=1492 After making the DSL connection at first, of course. IPv6 doesn't need to be stopped. Then reboot and updates are working, and software is visible in AppCenter. Commented Sep 14, 2016 at 13:56

2 Answers 2

3

I had this too. To fix run sudo apt update

Once it's done you can add PPAs after installing software-common-properties, although this is not recommended to ensure security and stability.

4
  • sudo apt-get update doesn't work either: E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ Commented Sep 10, 2016 at 8:07
  • So I killed all the apt processes and removed /var/lib/apt/lists/lock and /var/cache/apt/archives/lock. sudo apt-get update initiated, but it's very, very slow. After 1 hour and a half it still didn't finish, so I closed it. I was looking for a solution to speed it up, but couldn't find any (Epiphany is not opening all pages). Commented Sep 10, 2016 at 10:48
  • Maybe reboot? Sounds like something might be getting held onto by the system and preventing you from moving forward. Otherwise maybe try to reinstall. Commented Sep 10, 2016 at 13:18
  • I reinstalled and it's the same. It might just be an ipv6 problem, but I'm not sure, because also some websites don't load. I don't know if I properly disabled ipv6. Commented Sep 10, 2016 at 14:38
2

AppCenter displayed the installed apps only. Running sudo apt update did not solve the problem. I had to reinstall AppCenter to fix it.

  1. Remove AppCenter:

    sudo apt purge appcenter

  2. Reboot

  3. Install AppCenter:

    sudo apt install appcenter

  4. Update repositories:

    sudo apt update

  5. Open AppCenter.

1
  • I also had to resolve any repository related errors which were listed by apt-get udpate. Might be worth adding that to the answer
    – codecowboy
    Commented Apr 23, 2017 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.