6

My sound is broken and I have a hard time discerning if it's a hardware or software problem.

At the moment, the speakers on my laptop work, as I can hear sound just fine when I watch a video. However, in the sound settings plug in switchboard, when I try to test my speakers, I hear nothing from Front Left and Front Right. I don't know if that's a problem with my speakers or with the sound settings module. I've reinstalled (purge + install) switchboard-plug-gcc-sound in case any config went awry, but the problem still persists.

As for my headphones, sometimes sound comes through only one channel (right), sometimes both, sometimes neither. Again, in the sound settings panel, I hear nothing when I test the left and right channels.

The other day, I was getting no sound through my headphones: nothing from sound test, nothing from videos, but strangely the beep worked just fine in both ears. I booted into an elementary live-cd environment and heard the sound working just fine, including the sound test. I thought I'd save the config (~/.config/pulse) in the live-cd run and somehow incorporate that into my actual installation of freya, but once I booted back into it, all the sound was working again, including the sound tests, without me touching the config.

  • In the Sound settings, have you tried selecting different devices for sound output? – maliktunga Jul 27 '15 at 17:59
  • Do you run any out of the ordinary music or video players that may hijack the sound? Or something like Skype or Google Hangouts? – CameronNemo Aug 2 '15 at 2:18
  • you should know that elementary saves the volume when you have headphones connected and wen you have them disconnected as different settings. So, if you mute it while having your headphones connected and then you disconnect them it will unmute itself, then when you connect them again it will mute automatically. – santileortiz Aug 6 '15 at 20:31
  • I had find out that it's pulseaudio 8.0 was messed up, but in Jun was released pulseaudio 9.0 which has fixed this issue. How to check which version is used in eOS RC1? – user5608 Jul 18 '16 at 15:05
3

Try sudo apt-get install pavucontrol and see if maybe your pulseaudio settings are messed up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.