6

loving the new OS. Just installed Loki today and have a problem with screen brightness. My screen is at full brightness, which is a pain at night.

I have a MacBook Pro late 2013 11,3 with dual nvidia, intel graphics

Some steps I've attempted.

SYSTEM SETTINGS > POWER > DISPLAY BRIGHTNESS doesn't seem to do anything.

I ran ls /sys/class/backlight and got a returned result of gmux_backlight

I also attempted adding setpci -v -H1 -s 00:01.00 BRIDGE_CONTROL etc=0 to etc/local.rc based on another question & response here. But even after reboot, still no luck.

Anyone have any trouble shooting ideas?

One thing, I did not check install 3rd party drivers at setup. Is that part of the problem?

Thanks

  • Not work with intel graphic card Here is lspci output lspci 00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09) 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) 00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04) 00:16.3 Serial controller: Intel Corporation 6 Series/C200 Series Chipset Family KT Controller (rev 04) 00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04) – Sand Angel Dec 21 '16 at 13:45
2

I found that after running setpci I needed to reload the apple_gmux module, so my /etc/rc.local looks like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

setpci -v -H1 -s 00:01.00 BRIDGE_CONTROL=0
modprobe -r apple_gmux
modprobe apple_gmux

exit 0
  • 1
    This worked for me on my 2015 MBPR 15", thanks!! – horseyguy Jan 7 '18 at 19:57
  • I'm so glad it helped :-) – Brad Pitcher Jan 8 '18 at 21:45
1

This code works for me, same might help you.. give a try!

sudo apt install xbacklight

then run

xbacklight -set 15

15 is the percentage of backlight you gonna use. You can change any percentage value according to your need.

0

There is a typo in your command. This is the correct one:

setpci -v -H1 -s 00:01.00 BRIDGE_CONTROL=0

First of all execute it in any terminal app and then try to change the brightness pressing F1/F2 keys. Add this line to your rc.local only if it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.