When I went to install aptik, I tried to add the PPA in the terminal as I normally do with:

sudo apt-add-repository ppa:teejee2008/ppa

But I get the message:

sudo: apt-add-repository: command not found

Undeterred, I downloaded the .deb file and used gdebi (downloaded from the new Software Center) to install it, which it did fine.

But when I open Aptik from the Applications menu, it gives me the following error (see picture).

alert: command not available: add-apt-repository

What can I do? This is a show stopper for me if I can't add a PPA to restore my backup.


4 Answers 4


As far as I know it is intentional from the eOS team. I also had such issues in Loki beta. In order to add PPAs run the following in the terminal

sudo apt install software-properties-common
  • I installed this via the Software Center as Software & Updates, and now I can add ppas! Thanks!! Should I disable all updates? I don't want it pulling down updates that will break my system.
    – kingogames
    Commented Sep 9, 2016 at 19:03
  • 2
    This was an intentional change by the elementary team IIRC to prevent adding PPAs. Don't disable updates - this is normal and you'll be fine
    – Crutchcorn
    Commented Sep 9, 2016 at 19:16
  • 3
    @kingogames remember to mark this answer as accepted if it solved your issue.
    – Gabriel
    Commented Sep 10, 2016 at 2:48
  • @dan Do you know why they disabled? Commented Mar 1, 2017 at 6:34
  • 1
    This has been a fairly common practice in multiple modern distros as it helps avoid unintentional package injection by default.
    – Samuel
    Commented Jun 13, 2017 at 14:33

The following should install the tool to add apt repositories. Remember that elementary doesn't support or secure these, so they are entirely at your own risk.

sudo apt install software-properties-common python3-software-properties python-software-properties

You can also just install "Software & Updates" from the app center.


Make sure to run sudo apt-get update first I had to do this for the software properties to work


Not the answer you're looking for? Browse other questions tagged or ask your own question.