0

One of the reasons I started to use linux is boldly written on the Elementary website: No Ads. No Spying.

In that spirit, I also moved to Signal, which has a Chrome app. Two of my friends have installed it on their Windows 10 systems and it works flawlessly.

However, I am unable to get it to work. Contacting the Signal team was not helpful because they told me: we don't support "elementaryOS."

The app is stuck on the introductory blue screen without any logo or any text. Screenshot here.

If I close this window, and run Signal again from the Applications menu, it won't even start and get to the point it does, on first install.

I have tried reinstalling the chrome app as well as restarting my system, but neither helped. I also found out that Google Keep works fine, but Pocket doesn't. I'm not sure why this is happening.

I'm running elementaryOS 0.3.2 x64 and Chrome Version 52.0.2743.116 (64-bit)

  • I'm using elementaryOS 0.3.2 x64 and Google Chrome 53.0.2785.89-1 and it runs fine. Try to update your browser. – Thiago Jedi Sep 9 '16 at 3:47
  • Also... are you using Google Chrome or the open source Chromium? – Thiago Jedi Sep 9 '16 at 3:49
  • Upgraded to Google Chrome 53.0.2785.101 (64-bit) and still the same result. No broken or missing packages, everything is up to date too, now. The same app worked fine on my dual-boot Windows 10. sighs Using Google Chrome, not Chromium. – raisinrising Sep 9 '16 at 4:25
  • Just installed Loki -- the problem seems to have vanished on its own. Not sure what fixed it, but there was definitely something missing on my Freya installation. – raisinrising Sep 10 '16 at 8:13
1

Just installed Loki (elementary OS 0.4.0) and the problem seems to have vanished on its own. Not sure what fixed it, but there was definitely something missing on my Freya installation.

Perhaps a fresh Freya installation could also have fixed it. Nonetheless, it works on Loki. :)

  • And we're back to square one. Signal works, Google Keep refuses to sync any data. The circle loading animation keep going round and round. – raisinrising Nov 20 '16 at 5:38
0

From Wiki,"Signal's official Android client requires the proprietary Google Play Services because the app is dependent on Google's GCM " Maybe chrome is missing dependencies for it to be installed. what version of elementary & chrome are you using. Have all updates being done. When tou do your next update.Run "sudo apt-get update && sudo apt-get upgrade && sudo apt-get install fix-missing". The fixed missing, in case a pkg may be missing a component.

It is possible to "BUILD from SOURCE" follow the link here. https://timtaubert.de/blog/2016/01/build-your-own-signal-desktop/

I would suggest you wait to Friday for the release of elementary Loki stable. then see what happens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.