18

I've recently installed 0.4 Kodi Beta 2 on my XPS 13 as the broadcom WiFi chip installed on it only started receiving support on Ubuntu starting 16.04 on which 0.4 Kodi is based. So far everything has been working wonderfully (except for a few minor bugs in the software centre), but there's one thing that boggles me and I'd love to hear your input on it. Every time I resume the laptop from sleep, I get this popup asking for my password: enter image description here Sometimes I even have to input my password in several times because after clicking "Authenticate" the window shows up again. Is this a known bug? Does anyone know how to resolve it?

5
  • This is still occurring even after a fresh install of Elementary OS Loki post official release. Does anyone know how to deal with it?
    – tedodactyl
    Sep 29 '16 at 8:40
  • I've been getting this too, for the last 3 or 4 days. The only way I've been dealing with it so far has been to open a terminal and use xkill to kill the popup... a proper fix would be nice!
    – user6691
    Sep 30 '16 at 13:06
  • What other applications do you have open when you get this pop-up? Mail, perhaps?
    – wolf
    Sep 30 '16 at 17:24
  • I have Chrome running in the background, dropbox, and that's it...
    – tedodactyl
    Oct 4 '16 at 15:16
  • This is happening to me too as of March 20, 2018 and a fresh Elementary OS install.
    – Jody
    Mar 20 '18 at 22:37
8

Update: Should be fixed in the AppCenter 1.2 update, but try the following if it persists:


I haven't had this issue since I disabled the AppCenter from running in the background.

  • To kill AppCenter in your current session, run killall appcenter.

  • To disable AppCenter at startup, see Disable AppCenter dock reminder—there is a terminal way and a gnome-session-properties way.

1
  • In my case there is no process "appcenter" running. Still getting the prompt...
    – thoni56
    Sep 17 '18 at 17:21
8

Its a bug, already reported:

https://bugs.launchpad.net/appcenter/+bug/1617687

Im also affected, hope it will get fixed soon.

3
  • Good to know it's not just me. I hope a fix will be released sometime soon.
    – tedodactyl
    Oct 4 '16 at 15:28
  • I still have this issue and I want to keep AppCenter running so I know when to grab OS updates. Was a new bug report opened since? Jun 20 '17 at 15:22
  • That launchpad bug is closed. There's one on appcenter (github.com/elementary/appcenter/issues/499) that's still open though.
    – thoni56
    Sep 17 '18 at 17:23
4

Removing the App Center works for me.

sudo apt purge appcenter

You can always reinstall it later; after the problems are addressed maybe :).

1
  • a workaround I guess for now ... but certainly not a cure. Oct 28 '17 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.