1

Just returned to linux after few years, wireless internernet connects but damn slow even though it is not the case for my mobile phone or laptop (windows seven). Can anyone guide me to get rid of this ????

3

Method 1

What worked for me was installing the Wicd Network Manager.

sudo apt-get install wicd  

You may or may not also need to uninstall the default network manager.

sudo apt-get remove network-manager-gnome network-manager

Method 2

If /etc/nsswitch.conf has this line:

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4

Try editing it so it instead says:

hosts:          files dns

Method 3

Another suggestion is to type this in the terminal:

sudo modprobe -r rt2800pci  
sudo modprobe -v rt2800pci nohwcrypt=1  

And if the internet speed improves, then:

sudo gedit /etc/modprobe.d/rt2800pci.conf  

and type into the file:

options rt2800pci nohwcrypt=1  

Method 4

IPv6 can cause issues, so to prefer IPv4 instead:

sudo nano /etc/gai.conf

Locate this line (note that it says 100 at the end, not 10):

#precedence ::ffff:0:0/96 100

and remove the #.

Sources:
http://www.techdrivein.com/2012/09/slow-erratic-wifi-ubuntu1204-fixed.html
https://ubuntuforums.org/showthread.php?t=2175345
https://askubuntu.com/a/790022/628841

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.