0

enter image description here

After new important security and hardware support update, graphics are not working, it bootup until e logo but after that everything goes black but i can log in to the system using command line. Can anyone tell me how can i recover my broken system by live usb? I don't want to do fresh install because broken system has lots of application and data. please tell me how to fix the problem without loosing data. Thanks

HP ProBook 4540s (corei7) - 8GB ram, Radeon graphics, freya

0

There are still issues with AMD/ATI Raedon graphics with Ubuntu 16.04 (whose libraries the Hardware Enablement kernel allows. See Below:

Summarizing the info online: (from Phoronix)

"The last release AMD did can not be used because it is incompatible with the newer x.org version 1.18 display server. Switching distros will be of no help. X.Org Server 1.18 does bump the video ABI so that means the proprietary graphics drivers will need to see new releases... If you're using the NVIDIA Linux driver you're in good shape while AMD Catalyst users will need to wait for a new release, which could be a while considering the upstream driver still doesn't support the latest Linux 4.x kernel releases without third-party patches."

" AMD's Tim Writer commented in our forums that Ubuntu 16.04 won't be supported at all. "For those who don't know, I manage AMD's open source graphics team. We (AMD) are focusing our Linux graphics driver development on the amdgpu based open source and upcoming hybrid stacks; consequently, we are not supporting fglrx on Ubuntu 16.04 LTS. Users who require Pro-graphics or Workstation class features and performance can continue to use fglrx on Ubuntu 14.04 until the hybrid stack is available later this year." "

Problems with the new driver code: http://www.phoronix.com/scan.php?page=news_item&px=Massive-DAL-Driver-Woes112

http://www.omgubuntu.co.uk/2016/03/ubuntu-drops-amd-catalyst-fglrx-driver-16-04#comment-2564386159

As to how to recover from a Live USB, have you tried rolling back the upgraded libraries by purging the added files:

sudo apt-get purge linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial

Not sure if that would work to get you back to square one though, you may just have to reinstall. Hope you backed up your data! good luck.

  • Thank you very much for your comment. finally i have to do a fresh install. it was painful at least i could recover my files. Is there any way to block uncomputable updates ? – Praveen Aug 28 '16 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.