enter image description here I have installed above update and after that system cannot boot. it displayed the "e" logo and after that everything goes black again, does anyone know how to fix this? already tried recovery mode. nothing happened. Thanks os: elementary OS freya

  • What hardware are you running? Do you get any error messages, or just a black screen? Thanks! Commented Aug 23, 2016 at 15:06
  • HP ProBook 4540s (corei7) - 8GB ram, Radeon graphics. did you get the same error?
    – Praveen
    Commented Aug 23, 2016 at 15:08

3 Answers 3


Finally i have to do a fresh install. don't know what will happen when i upgrade to the Loki. I know this is not the best solution. but i mark this as "accepted". if anyone know how to ignore unsupported updates feel free to comment below. it maybe a proactive solution for this.


The latest version of Ubuntu switched to an open-source Nvidia driver, which causes problems for some people.

You may be able to solve the problem by booting into recovery mode and installing the proprietary Nvidia drivers.

To start, we'll boot into recovery mode, enable networking, and get to a terminal prompt:

  1. Restart your computer. If you dual boot, grub will appear. Otherwise, hold shift while your computer boots to open grub.
  2. From the options that appear in grub, choose recovery mode. The recovery mode option will look something like this: elementary OS, with Linux [version details] (Recovery mode).
  3. The system will boot into recovery mode. After a few moments, the recovery mode menu will appear.
  4. Choose "enable networking". Answer "yes" at the dialog that appears.
  5. Choose "drop to root shell prompt".

At this point, you should have a text prompt where you can download and install the driver.

Next, we'll install the Nvidia drivers. I don't have an Nvidia chip on my computer, so I've copied the following steps from this Ask Ubuntu question.

  1. Run sudo apt-get purge nvidia-*
  2. Run sudo add-apt-repository ppa:graphics-drivers/ppa and then sudo apt-get update.
  3. Run sudo apt-get install nvidia-364.
  4. Reboot.
  • Can you tell me how to enable terminal in recovery mode? every time i enter in to the recovery mode it end up with normal boot. Thanks
    – Praveen
    Commented Aug 23, 2016 at 16:25
  • I'm not affected by this, but... really?! An Ubuntu security update just switches your drivers?! I can't believe that, it would be that much irresponsible. I had spent nights on getting the NVIDIA graphics drivers up & running on my girlfriend's laptop with EOS Freya... @Praveen: Not sure about recovery mode, but a chroot should work easily. Google should give you an easy-to-follow guideline for Ubuntu (which should be compatible), depending on your language of preference.
    – kostrykin
    Commented Aug 23, 2016 at 19:13
  • @Praveen, I've updated the answer with details on how to get into recovery mode and get to a terminal. Does that help? Commented Aug 23, 2016 at 23:58
  • @RyanDeBeasi Thank you very much for help. i have installed nvidia drives as you mentioned, but it didn't work. maybe do i need to install radeon graphics ?
    – Praveen
    Commented Aug 24, 2016 at 14:47
  • @theV0ID Thanks for the comment? by chroot mode can i recover ? (i'm new to Linux ).
    – Praveen
    Commented Aug 24, 2016 at 14:48

OK. I can confirm the other answer is actually working.

with one exception.

I wasn't able to start my grub, but I was able to ctrl + alt + F1 into my terminal, where I have fully running Freya, just without a front end.

NOTE This is only a solution if you previously installed proprietary NVidia driver, and you will need to use your Nvidia installer to recover.

to get your front end, steps are:

  1. wait until your screen is blacked out, hit ctrl+alt+F1 into terminal.

  2. in terminal check if you can turn off you x server by:

service lightdm stop

if it says unknown instance, then you ignore it for the moment.

  1. now get your Nvidia installer to do the following:

~$: ./NVIDIA-Linux-x86_64-361.45.11.run --uninstall

NOTE if you did what Ryan (the other answer) said, using apt-get purge to remove it, you will still need to do this step.

  1. now restart and boot into terminal again.

  2. now run:

~$: chmod +x NVIDIA-Linux-x86_64-361.45.11.run

~$: sudo ./NVIDIA-Linux-x86_64-361.45.11.run

  1. follow the instruction to complete NVIDIA installation.

  2. once complete you can run:

~$: service lightdm start

you should now see your GUI back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.