0.3.2 Freya on a

  • i7-3537U CPU 2.00GHz,
  • NVIDIA GK107M [GeForce GT 740M]

After getting the dialog box this user got, I searched for a solution and eventually used this one: Kernel version is still 3.16 on Freya 0.3.1

There is a warning, that now I'm now rereading in its full... seriousness: "Warning! Be careful and attentive to this, the system can fail. Check packages that will be removed before pressing Y."

And in my case there was two packages. One that had to do with thunderbird and another. That other, I am thinking, did the trouble.

Well, because I am pretty close to a complete ingnorant when it comes to code, I cannot even remember the name of the package. And now, I fear that when I used the "auto remove" command suggested after running the commands that one package is now missing and prevents my machine from booting.

Is there something I can do now to save it? Tomorrow, in a little more than 24h, I have a work deadline, and really thought that this would be just a routine upgrade. I'm using a borrowed machine to write this, but very important files are burried there.

What can I do? Any help is apreciated.

  • What comes up when the system tries to boot?
    – RolandiXor
    Aug 22, 2016 at 18:56
  • Everything seems normal, the "e" comes up and then everything goes black and there is no light indicating that the hard drive is having any activity. And it stays that way. Ok, I see the imprecision in my semantic, sorry. It comes from not working with tech. It boots and then stalls. It fails to go to the logon screen.
    – hainish
    Aug 22, 2016 at 19:19
  • I have already tried different options: loading the other kernel (I think it is the kernel) 3.19. And loading in security mode, both the 4.40 and the 3.19, in security mode and standard. But the outcome is the same. I have a flash boot disk and have have already loaded from it to make a backup of my files. But it would be so much better If I could have a solution other than a fresh install.
    – hainish
    Aug 22, 2016 at 19:23
  • Because I had a deadline and had to use the computer, I already did a fresh install. In that process, the option to update while installing turned out to be a bad one. Because after booting, it stalled in a black screen and did not go to the logon screen, again. So, I had to do a second fresh install. Hope this info is useful for anyone going through the same process. Now, I'm back where I was, because I'm faced with the same dialog box. I will follow updates on this, or open another thread. This one can be closed.
    – hainish
    Aug 24, 2016 at 12:20
  • @hainish, would you mind adding an answer explaining what you did to fix the problem (even if it's just doing a fresh install) and marking that answer as "accepted"? That way, this question will show up as resolved and other people can learn from your experience. Thanks! :) Aug 24, 2016 at 13:36

2 Answers 2


I had the same problem and it showed a black screen after the boot logo. But then on the black screen I pressed enter and then entered my password. Then after a while when I pressed the volume button it made the noise hence confirming that there something went wrong with the graphics driver. So,from the Grub loader I went to the recovery mode and then to the root shell and removed the Nvidia Graphics card driver by using

sudo apt-get remove --purge nvidia-*

After reboot I was able to get the login screen back. There were issues with my wifi connectivity too , so I reinstalled the wifi driver by

sudo apt-get install bcmwl-kernel-source

This worked for me :)

  • Hope that's helpful for someone. As I had mentioned in my answer, I already did a fresh install.
    – hainish
    Aug 28, 2016 at 16:25
  • Back to my initial problem. After setting elementary OS, from my backup files (after a fresh install) I read in another thread that a user was surprised to hear that the software update program did work for him. So, I tried it, and it worked. There was no error message. But... after the first boot. This black screen. I am trying to implement your solution. The thing is, I don't have a grub loader. It boots automatically. Only when booting from a flash drive (it's grub 2.0). But in that case there is no recovery mode option. I tried the left shift, Did not work either. Any thoughts?
    – hainish
    Aug 30, 2016 at 17:05
  • Online, I have searched for instructions on how to load the grub, or how boot into security mode, and found this: askubuntu.com/questions/150367/how-do-i-boot-into-recovery-mode Following 3. Quickly press and hold the Shift key (or Escape key on some computers) I have found that on my computer it is the Esc. key. But it only allows me to choose the boot device or load the BIOS and not to either load the grub nor choose security mode boot.
    – hainish
    Aug 30, 2016 at 17:15
  • Reaching a deadlock, went for another fresh install. And this time, I updated the machine before installing anything in it (even drivers). And it worked fine.
    – hainish
    Aug 30, 2016 at 22:06
  • this worked for me thank you. I boot into recovery mode after pressing the esc key on my dell laptop then followed your commands Oct 20, 2020 at 17:34

With no other solution, I did a fresh install.

For other users, that have to do a fresh install when running into the HWE hardware-enablement stack impass, be advised:

don't chose the option to update while installing. I did, and it got me exactly in the same place. A stall after booting and not going to the logon screen.

Following @Ryan-DeBeasi advice, I'm answering my own question so I can mark it as "accepted". But I will have to keep looking for help on the hardware-enablement stack impass, because I'm back to square one on that.


After trying to update, with the software updater, the same thing happened all over again.

It's now pretty safe to say that a fresh install works, with the options to update while installing and also to install proprietary drivers turned off (for safety). After bootting for the first time all is fine and the hardware-enablement stack dialog shows up. And installing that update also works, no problem there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.