6

I'm having difficulties installing elementary OS Freya in UEFI mode. My BIOS supports both legacy and UEFI. With other Ubuntu distros my boot menu gives me the option to boot the live CD or usb using legacy or UEFI. With elementary OS it's only giving me the legacy option. I tried downloading a new ISO and it didn't make a difference. Also tried usb and cd. Any help would be appreciated!

1

Is this a single boot or a dual boot installation? You can boot the live distro and manage your drive with gparted. You need to make a uefi partition (fat 32, boot flag) and a seperate one to install your distro to. You can fire up the installer from there. When doing a single boot, auto install elementary os and the installer will pick the uefi partition to place the boot files. Have you read this link: https://help.ubuntu.com/community/UEFI

I hope this is helpful.

  • 1
    If you use Gparted after booting from a live distro, all you need to do to "force" a natural UEFI installation is wipe all the HDD space as "unallocated" space under GPT format table. elementary OS installer will take care of the rest. – Jorge Jul 31 '15 at 15:50
1

Boot Repair can be helpful, here's a good article about its installation and usage http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/

  • Please expand the answer so that the questioner does get the answer, include links for only reference. – Aditya ultra Sep 29 '15 at 4:20
1

I was able to successfully complete the installation by following this tutorial, I booted first in legacy mode to install then after having completed to install rEFInd (just download it, and execute install-refind.sh) I have reset the bios to the UEFI mode and rebooted. After this steps you'll see that the rEFInd UEFI menu is loaded instead of the original Windows one. Good luck!

0

Does UEFI / BIOS have an option to select EFI file for boot (try F12 ,F11 or look at the PC manual)?

If yes, choose /EFI/BOOT/grubx64.efi from the install media

0

Also have had issues to install elementary OS freya on my new ASUS X556U in dual boot windows10/eOS. this windows version is older than july 29, 2016.

I first followed theese steps (found there : https://itsfoss.com/guide-install-elementary-os-luna/) :

  • create a live USB of Elementary OS Freya and let the usb key in its port

  • defrag windows

  • note the memory reserved to Windows (C ?) and to the Data (D?) in order not to make an error in the future partition step

  • restart windows
  • when it is loading press F2 to access the BIOS (it seems that F1, 10, 11, 12 can work on others PC)
  • in the Security tab disable "secure boot"
  • in the Boot tab enable "Launch CSM" and "Launch PXE opROM policy" (wich in the right column refers to "control the execution of legacy opROM")
  • press F10 to save and exit
  • restart and when it is loading press AND HOLD Esc.
  • choice to start with USB device (or the mark of the usb key) but not the EFI one
  • I did what itsfoss wrote about partitions with a few differences :

--> I didn't delete one device but changed the existing data device from 600000 to 200000 Mo in order to create free space.

--> Then I added a 20000 Mo "/" logical beginning ext4 partition (root), a 12000 Mo logical beginning swap area (12 Go is my 6Go RAMx2) (swap), a 100 Mo BIOS boot partition (grub) and a "/home" rest-of-the-free-space Mo logical beginning ext4 partition (home).

  • and followed instructions until a note asked me to restart the system.
  • wich refused to start another OS that windows.

Then I fell into research about grub, boot-repair and sudo apt-get during 3 hours.

Next https://forum.ubuntu-fr.org/viewtopic.php?pid=20542461#p20542461 saved my mind.

  • I followed its instructions :
  • start with windows (I didn't have any other choice anyway)
  • right click the window logo in the left bottom corner
  • search the "settings"
  • find "update and security"
  • select "recovery" and "restart now"
  • choice the device option with "EFI" in the name (first choice in my case)
  • follow the steps on the screens .
  • at the partitions steps you will see a new partition on the top of the list called "efi" which is the grub of Windows. So our first grub (BIOS boot partition) does'nt serve anymore i guess. But im not sure and did'nt delete it. For the others partitions the names "/" and "/home" of my ext4 partitions had disappeared in my list so i named them again and checked the "format the partition" box for both.
  • the rest of the steps is well known now

THAT WORKS FOR ME !!

(sorry for the translate)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.