I have a freya 0.3.2 / Win 10 dual boot system with an encrypted home folder on a separate partition. Recently I changed my user password in the system settings. As a result, I could not log into the system anymore. When I entered the password in the pantheon greeter prompt, the screen would go black for a split second (including some output that was impossible to read so quickly) and then returned to the pantheon greeter prompt. I then had to do a reinstall of the system to be able to log in again.

Two questions I have:

  1. Is this a bug or a deliberate design choice to protect the home folder encryption? To me it looks like a bug because when you change your password in the system settings you effectively lock yourself out of the system. I think there should at least be a prompt or some info in the system settings that lets you know that you're not able to change your home folder encryption password in the system settings

  2. How can you change the password for home folder encryption? Is that possible at all? You certainly cannot do it by reinstalling - I've tried that too, if you pick another password in the install routine, the system will just hang after Pantheon greeter and not load the desktop environment. Upon reinstall choosing the old password it'll work again.

Any ideas?


2 Answers 2


If you have the same thing, you can solve it without reinstalling the OS:

  1. Boot your system in nornal mode
  2. in the pantheon greeter prompt pressCtrl+Alt+F1 to drop to TTY1
  3. login with your new password
  4. change your password yo previous.

Unfortunately, i don't know how to change \home folder encryption passkey.(


I encountered the same problem the other day. To update your encryption passphrase to match your login password, you need to use the ecryptfs-rewrap-passphrase command. There is a more detailed answer in my post here: https://elementaryos.stackexchange.com/a/7949/5722.

Furthermore, I have tried to replicate this issue but have been unable to. Using System Settings to change my password seemed to reliably update the encryption passphrase in all subsequent attempts.

Not the answer you're looking for? Browse other questions tagged or ask your own question.