1

good morning , I have a question with the theme of the icons is as follows , I would like my files I have , if they are a pdf I display an icon indicating that it is a pdf, not to show me the preview, anyone knows how you can change ?. A greeting.

  • This question has been asked here: elementaryos.stackexchange.com/questions/3995/… – Clayton McCray Jul 31 '16 at 21:55
  • Hello, thanks for answering . The question I have is that what you refer to me as I have , when I access a folder where you have the PDF, first shows me the icon, but after a few seconds , shows me the preview of the file, there is no icon pdf . Regards, and thank you very much. – A.Crego Aug 1 '16 at 8:28
  • I think what you are asking is how to turn off thumbnailing, perhaps because it slows the computer down too much? Unfortunately there isn't and option to do this at moment from within Files. There may be a way of disabling the thumbnailer (Tumbler) at system level but that would affect all applicaitons. – Jeremy Wootten Aug 1 '16 at 18:36
  • After a little Googling I found this link askubuntu.com/questions/232347/…. If you do not mind messing about with configuration files you can disable any (or all) thumbnailers at a system level using the method described at this link. – Jeremy Wootten Aug 1 '16 at 18:45
  • An easier way is to use dconf to edit the setting org.gnome.desktop.thumbnailers.disable to disable thumbailing of certain mime-types or org.gnome.desktop.thumbnailers.disable-all to prevent thumbnailing altogether. – Jeremy Wootten Aug 1 '16 at 18:48
1

tumbler is managing which thumbnails are generated in elementary OS .
In order to customize the tumbler config file, you can make a local copy by creating a tumbler folder in ~/.config and then copying the original config file tumbler.rc from /etc/xdg/tumbler to that folder.

The easiest way to do it, is to use these commands:

mkdir -p ~/.config/tumbler
cp /etc/xdg/tumbler/tumbler.rc ~/.config/tumbler/

Now, edit the file with your text editor

scratch-text-editor ~/.config/tumbler/tumbler.rc

search for the section

# PDF/PS thumbnailer
[PopplerThumbnailer]
Disabled=false

and change Disabled=false to Disabled=true. The changes should take effect after a relogin or restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.