2

In May my elementary OS network stopped working. I cannot connect to wifi or Ethernet. It seems the last update caused the network problem. Looking for the solution I came across this How can I fix Networking, Wi-Fi and Ethernet, not being available after update? I want to fix my network issues but I am having trouble understanding Step 2: Downgrade the Packages and Restart the Service.

I am still very new using non-windows/OSX operating systems such as linux. Can somebody explain to how exactly to downgrade the libnl packages? I have downloaded and saved the 3 libnl packages (from the link above) in my documents folder in elementary OS. I have tried to run sudo dpkg -i libnl-*deb command in terminal then I'm prompted to enter my password. I enter my password and I receive this error.

> dpkg: error processing archive libnl-*deb (--intall):
>  cannot access archive: No such file or directory 
> Errors were encountered while processing: 
>  libnl-*deb

I am not entirely sure what I'm suppose to do. Can somebody help me out with a simple noob step-by-step guide. I really like using elementary OS but I can't seem to figure this out. Help would be appreciated thanks.

1

You can try disabling Secure Boot in the BIOS if you have such a setting. My Braodcom wireless won't work anymore after software updates and with secure boot enabled.

0

All the libnl packages are here.

http://packages.ubuntu.com/search?suite=default&section=all&arch=any&keywords=libnl&searchon=names

If you're using eOS Freya, then that would be the Trusty version for Ubuntu.

Which version do you already have and which ones do you need?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.