5

I was cleaning up some unneeded files in my Rails project when I accidentally deleted files that are VERY important to my project.

I realized my mistake and went to the Trash and found what I needed to get back. I right-clicked and picked "Restore from Trash". The file system crashed and I don't have any of my files back. I tried this maybe 50 times along with just clicking "Restore All". Same result, the window crashes every time. There is a tiny lock next to the folder I need and as far as I can tell every other folder.

Does anyone know how to fix this?

2

To open your Trash in a window with superuser powers in Loki, run

sudo -i pantheon-files /home/$USER/.local/share/Trash/files/

This command runs your files program (pantheon-files) as the root user (sudo) in the root's environment (-i) at the specified directory (your personal Trash folder). No need to change $USER, which will automatically translate to your current username.

From this window, you should be able to move your files as you please.

0

Try opening Files as administrator and restoring that way:

Open Applications

Right click on Files and click New window as Administrator

Try to restore/copy that way

or

In terminal

sudo mv /home/your_username/.local/share/Trash/your_file /your-restore/location

  • Thanks for answering: There was no open a new window as Admin option given and this is going to sound ridiculous but keep in mind I am not very experience with Linux, hence elementary os, I can't find the trash folder via the terminal. – Lenocam Aug 10 '16 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.