2

Computer: Acer Aspire 4752 Intel core i3-2330M, 6GB RAM,500GB HDD

I had the 64-bit elementary OS Luna with the following disk partitions:

  1. /dev/sda1(400GB) as /home
  2. /dev/sda2(30GB) as /root
  3. /dev/sda3(5gb) as swap
  4. /dev/sda4 as boot(efi?)

Rest as unallocated space, I installed elementary OS Freya (64bit) using the "something else" option and leaving my home partition as is. Now when I boot I am stuck at this screen:

enter image description here

I tried the manual recovery but can't get any further than this:

enter image description here

Now I tried pressing Ctrl+D, the black screen then says Warning : Fake initcl called, doing nothing . Well, nothing happens and I have to force shutdown, running startx doesn't help either just a completely blank screen appears. This is my primary computer and I don't have anything to backup my data to, any solution which doesn't have the risk of loosing my data would save my day.

PS: I used the same username and login password as before. Now would be investing in an external HDD.

  • Linux has two unrelated encryption mechanisms: dm-crypt, for full-disk encryption, which is what your swap space uses, and ecryptfs, for per-directory encryption, which is what you use for your personal files. That's a sensible combination, but it seems that something went wrong with the installation. This may warrant a bug report, but you need to describe exactly how you did the installation and what the current state of your system is. – Gilles 'SO- stop being evil' Jul 23 '15 at 19:54
  • Edit your question to the output of the shell commands cat /etc/fstab and cat /etc/crypttab and lsblk . Did you mention anything about encryption during installation? – Gilles 'SO- stop being evil' Jul 23 '15 at 19:56
0

I managed to solve my issue by re-installing and not using swap at all, as I have a 6GB of physical memory.The encrypted home partition is now mounted by default and everything works fine barring a few glitches here and there.

I now am facing entirely new issues related to lightdm and elementary desktop which require a new question. It's not actually a solution because the problem I had was rather interesting might have taught something new to me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.