I tried to install the editor Brackets using the originial .deb from the website, but dpkg and apt failed to do so.

$ sudo dpkg -i Brackets.deb 
Selecting previously unselected package brackets.
(Reading database ... 264099 files and directories currently installed.)
Preparing to unpack Brackets.deb ...
Unpacking brackets (1.7.0-16898) ...
dpkg: dependency problems prevent configuration of brackets:
 brackets depends on libgcrypt11 (>= 1.4.5); however:
  Package libgcrypt11 is not installed.

dpkg: error processing package brackets (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:

$ sudo apt-get install brackets 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
brackets is already the newest version (1.7.0-16898).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 brackets : Depends: libgcrypt11 (>= 1.4.5) but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

How can I install brackets? I've already installed libgcrypt11-dev and libgcrypt20

$ sudo apt-get install libgcrypt20 libgcrypt11-dev 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgcrypt11-dev is already the newest version (1.5.4-3+really1.6.5-2).
libgcrypt20 is already the newest version (1.6.5-2).

2 Answers 2


This is a known issue as you can see here and here. The proposed solution is to install this version of libgcrypt11.


run sudo apt-get -f install

and then re-run the deb installation using dpkg.

From man apt-get

-f, --fix-broken
        Fix; attempt to correct a system with broken dependencies in
        place. This option, when used with install/remove, can omit any
        packages to permit APT to deduce a likely solution. If packages 
        are specified, these have to completely correct the problem. The 
        option is sometimes necessary when running APT for the first 
        time; APT itself does not allow broken package dependencies to 
        exist on a system. It is possible that a system's dependency 
        structure can be so corrupt as to require manual intervention 
        (which usually means using dpkg --remove to eliminate some of the 
        offending packages). Use of this option together with -m may 
        produce an error in some situations. Configuration Item: 

In simple words this will install all the dependencies that is preventing you from installing your deb.

  • 2
    You should explain what this does for the sake of the OP.
    – RolandiXor
    Jul 31, 2016 at 5:47
  • Thank you, but if it had been so simple I wouldn't have to ask this question here ;) Installation fails with sudo dpkg -i Brackets.Release.1.7.64-bit.deb and sudo apt install Brackets.Release.1.7.64-bit.deb and sudo apt-get install brackets. To be sure, I ran sudo apt-get -f install between every try. Any ideas?
    – Kurztipp
    Aug 8, 2016 at 22:11
  • @Kurztipp Use this link And install the deb package and see if it works. The package dependency (libgcrypt11) you require is now obsolete for Newer Ubuntu Versions. Try the above link. Aug 11, 2016 at 14:30
  • I tried and it worked. Ran the sudo -apt-get -f install and then tried the brackets latest version. that fixed the issue
    – Gokul
    Oct 6, 2017 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.