2

I have multiple partitions; three of them are EXT4 and have a Linux system installed on them; two of them are NTFS and one of them has Windows 7 installed.

The second NTFS partition is almost half of the entire drive and is the only one that is not hosting an OS. It is a sort of deposit where I store text, image and multimedia files accessible from all installed OS-es and where most copying & pasting takes place. Only on this one an odd thing happens (and only in elementary OS): when I drag & drop selected files onto a folder (same directory level), the files are copied (like copy-paste) instead of being moved (like cut-paste).

On all the other partitions (ntfs and ext4), drag+drop=move.

(With the right mouse drag&drop opens the dialog that asks what to do, and then move works.)

I have tested this in both Freya and Loki.

What can be the cause? How could I investigate this farther?


UPDATE after testing other file managers:

  • This also happens in Thunar - therefore not panthon-files-specific

  • This doesn't happen in PCManFM

  • Using the latest version of Files (0.4) in Loki beta, I cannot reproduce this behaviour. Drag and dropping files within the same file system results in a move not a copy. If you use the secondary button to drag and drop then you get a menu giving a choice when you drop the file. – Jeremy Wootten Jul 23 '16 at 20:18
  • @JeremyWootten - What you say made me test more, and the result is very odd: I have multiple partitions, one of which is an NTFS partition taking almost half of my entire drive, and the only one that is not a system partition. Only on this one I had tested what I have initially reported in the question. I have also other partitions that all have an OS on them, one of them a NTFS partition with Windows 7. On all of these (one NTFS and two EXT4) it's as it should: drag+drop=move. Except on the big NTFS one. – user170 Jul 24 '16 at 18:35
  • @JeremyWootten - I have tested the same thing in both Freya and Loki. The problem is solely on the big NTFS partition. I have to radically edit my question. – user170 Jul 24 '16 at 18:36
2
+50

Loki is still a new release so there are still a lot of bugs worth reporting. Even in attempting to reproduce your situation, I ran into all kinds of non-standard behavior: files that refused to drag, files that copied when they did not show a green "plus" indicator, and so on. It's possible that what you observed is a bug to file. I don't see any bugs like this filed right now.

Long story short, I was not able to replicate your issue (file, when dragged into folder at same level, creates copy instead of move). I tried several drives, formatted each with NTFS and Ext4 partitions, and dragged a text file around. Pantheon Files consistently copied between partitions and moved within a single partition, no matter the format. Without more context, we would not be able to know whether this is an issue with permissions, NTFS, its interaction with the system, etc. I'd start with comparing the permissions on the two NTFS drives and filing a bug report with screencaptured video.

  • If I'm not asking too much, how do I compare the permissions? – user170 Sep 29 '16 at 6:54
  • Without delving into the permission notation, the easiest method would be to right-click > Properties on the desired folder/drive and look at how the permissions work in the various folders where you're having problems, and see if there are any patterns. I wouldn't expect much from that, but it's worth a shot if we have no other way of triaging why you observe a folder acting abnormally – wolf Sep 29 '16 at 17:54
  • Oddly, this doesn't happen in PCManFM. But it happens in Thunar. – user170 Nov 29 '16 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy