0

This question already has an answer here:

Background: In loki-beta2 I have some troubles with my touchpad. Sometimes my touchpad becomes unresponsive mid-movement until I release finger from touchpad and put it down again. Trial-'n-Error and some comparison to ubuntu yielded that libinput might be involved in this.

Questions:

  • Can I disable libinput-driver in loki and go back to stable synaptic-driver? Or will it have negative consequences else where?

  • If so, what is the proper way to do it? (At the moment I out-commented stuff in /usr/share/X11/xorg.conf.d/90-libinput.conf)

marked as duplicate by Lewis Goddard Oct 19 '16 at 0:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

I just posted a solution for another question that might help you for this as well on:

Way to enable vertical two-finger scrolling, but not horizontal?

I removed the libinput drivers for the touchpad and installed the synaptic drivers instead I did:

sudo apt-get remove xserver-xorg-input-libinput libinput-tools

This removes libinput touchpad driver. Then install synaptics:

sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics

Then restart.

This also allowed me to change Two Finger Horizontal scrolling and add palm detection (see above link) and also made the touchpad less sensitive.

I have not tested this extensively, but seems to work so far, use at your own risk. You could always remove the synaptics packages and reinstall the libinput ones if needed.

Jay

Not the answer you're looking for? Browse other questions tagged or ask your own question.