0

I have some annyoing problem, the Software & Updates won't start when I click on it, but Software Center works fine. Also I noticed that sometimes, Software Updater automaticly turns on promting me with some updates, but when I click on "Install now" nothing happens. I can only press X to close it. This wasn't happening before and I don't know when it started.

I also searched trough search results but nothing worked.

When I run in terminal software-properties-gtk I get this result

/usr/lib/python3/dist-packages/gi/overrides/Gtk.py:1511: Warning: /build/buildd/glib2.0-2.42.2/./gobject/gsignal.c:1211: unable to lookup signal "window-state-event" of unloaded type 'GtkDialog'
  initialized, argv = Gtk.init_check(sys.argv)
/usr/lib/python3/dist-packages/gi/overrides/Gtk.py:1511: Warning: g_signal_add_emission_hook: assertion 'signal_id > 0' failed
  initialized, argv = Gtk.init_check(sys.argv)

** (software-properties-gtk:31131): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-jSJfg1tbIe: Connection refused
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 37, in <module>
    from softwareproperties.gtk.SoftwarePropertiesGtk import SoftwarePropertiesGtk
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/SoftwarePropertiesGtk.py", line 46, in <module>
    from .DialogCacheOutdated import DialogCacheOutdated
  File "/usr/lib/python3/dist-packages/softwareproperties/gtk/DialogCacheOutdated.py", line 28, in <module>
    from aptdaemon.gtk3widgets import AptErrorDialog, AptProgressDialog
  File "/usr/lib/python3/dist-packages/aptdaemon/gtk3widgets.py", line 42, in <module>
    gi.require_version("Vte", "2.91")
  File "/usr/lib/python3/dist-packages/gi/__init__.py", line 83, in require_version
    (namespace, version))
ValueError: Namespace Vte not available for version 2.91

Similar result I also get when I run update-manager

0

Those 2 applications are just graphical front ends for apt. This kind of thing is common with them. Open a terminal, and do:

sudo apt-get update
sudo apt-get upgrade

This may fix or it will tell you what the underlying problem is.

Edit...

Found an old bug report regarding this. Probably a long shot but make sure package gir1.2-vte-2.91 is installed.

  • OK I tried upgrade and this is the result. The following packages have been kept back: linux-generic-lts-utopic linux-headers-generic-lts-utopic linux-image-generic-lts-utopic linux-signed-image-generic-lts-utopic linux-tools-virtual-lts-xenial shim-signed 0 to upgrade, 0 to newly install, 0 to remove and 6 not to upgrade. – facyber Jul 18 '16 at 9:52
  • You did update first as its important. That's fine, does software & updates work now . – Dave G. Jul 18 '16 at 10:29
  • It didn't worked, so I tried sudo apt-get distro-update and it upgraded those packages so now I'm getting The following packages were automatically installed and are no longer required: linux-image-3.16.0-34-generic linux-image-extra-3.16.0-34-generic linux-lts-xenial-tools-4.4.0-28 linux-signed-image-3.16.0-34-generic linux-tools-4.4.0-28-generic Use 'apt-get autoremove' to remove them. – facyber Jul 18 '16 at 10:38
  • In my experience its never a good idea to do distribution upgrade, but it's done now. so fingers crossed. Do: sudo-apt-get autoremove as requested and then 'sudo apt-get --reinstall install python-apt update-manager' – Dave G. Jul 18 '16 at 10:56
  • Still not working. Even with reinstalling python-apt. Is there some command to get log output to see why doesn't open apps? – facyber Jul 18 '16 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.