0

I added keyboard shortcut for gnome-terminal (I preffer this one). When I just create it, it works. After reboot it does not, so I assume something does not start properly on boot. 1. Can I add it manually, without system settings, willing that it would work. 2. Whats the process I should turn on and how?

Btw. I use arch linux with pantheon.

1

Please consider asking your question on an Arch forum (like bbs.archlinux.org), because I'm not sure if these commands apply on Arch.
On eOS I can use gsettings to change the keybindings via terminal.

First get the current binding with your logged in user:
gsettings get org.gnome.settings-daemon.plugins.media-keys terminal
The output is something like:
'<Primary><Alt>t'

To change this, you can use:
gsettings set org.gnome.settings-daemon.plugins.media-keys terminal "YOUR-KEYS"
Use the same syntax as in the output earlier and put it in quotation marks. As far as I know, gsettings doesn't check if these keybindings are already in use, so to be sure just try them, before hitting the set command.
After that you can rerun the get command, to check if it worked or hit the keys you specified.


EDIT: I think, I misunderstood what you want..
In the case you want to change the default terminal-application, the commands would be:

Get the current value and the correct syntax:
gsettings get org.gnome.desktop.default-applications.terminal exec
Example output: 'pantheon-terminal'

Set gnome-terminal as default:
gsettings set org.gnome.desktop.default-applications.terminal exec "'gnome-terminal'"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.