I am running elementary OS freya which is based on Ubuntu 14.04, I have a lenovo U41-70 laptop. My horizontal mouse movement is fine but to bring the mouse from top of the screen to the bottom (vertical Movement) I have to swipe my finger on the touchpad 3-4 time. I tried setting the touchpad Vertical and Horizontal Resolution to 75 and also editing the Finger High, Low and Press attributes in xinput. Nothing works.

1 Answer 1


Thanks for providing the necessary information, after a lot of googling and reading bug reports, it seems the main solutions are as follows, I'll start with the easiest although I know you have already tried it.

  1. Adjust the touchpad settings using synclient. synclient -l will give a list of options, for your problem in particular I would start with pressure settings, in particular synclient PressureMotionMinZ=25. Changing synclient settings is not permanent so when you work out which ones to change you will need to add some start up commands but on the other hand if you mess it all up you can just reboot to start again.

  2. Update your kernel. The bug reports reported bugs in kernels 3.3 right through to 4.2 with various issues with the alps touchpad, although I couldn't find anything specific to your problem. Kernel v4.4 is available however in the standard repos so you could try:

    sudo apt-get install linux-image-generic-lts-xenial
  3. Build your own Kernel Module (driver). I wouldn't try this unless your comfortable with building from source code but you can find instructions by googling 'dkms alps touchpad'. Don't forget to update your initramfs after you build your own module.

    sudo update-initramfs -u

Sorry I couldn't be more help but with these types of bugs and without the ability to sit on the computer and run various tests it's hard to diagnose it down to one specific problem.

  • I am really sorry. I forgot to mention that I have an ALPS touchpad. Feb 12, 2017 at 7:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.