1

At first, I installed fish shell and used it for some time. but just now I wanted to uninstall fish shell , then I run sudo apt-get purge fish and logged out. However, when I logined again. I opened the terminal but there was no prompt about command line. there was nothing! When I clicked the closure button, the OS logged out! Besides, I changed into tty(1-6) and input my username and password. the tty showed my password incorrect. I couldn't login into tty. I am really worried my OS, Is there somebody could do me a favor. Thanks!

1

Good news! I fixed this problem!

In the just moment, I had tried many ways to recover my OS including download other shells(I downloaded Gnome shell,actually, It doesn't work) and enter the recovery model when the OS start(It often locates under the item of OS and has two or more models). Of course, the latter method worked, when you enter the recovery model you should select the 'dpkg' item and it seems only in this item you have write permission. Before you modify some files the OS will ask one or two questions(Just input 'Yes'), then you can operate the OS as super user.

What I need to do is that

vi /etc/passwd

and change mine default bash to

/bin/bash

You should find your own username(It often in the end of the file).

At this time, this crash had been fixed. Just log out the recovery model and reboot.

Have fun with your recovery OS!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.