I tried to install Elementary OS Loki on my dell XPS 13 (8350) as Freya didn't support the Broadcom BCM4350 wifi card. This card works out of the box with Ubuntu 16.04, but isn't recognized by Loki. How is it possible ? Note that I tried several distrib based on Ubuntu 16.04, and none seems to recognize or make the wifi card works well, which is very strange because as I said, it works really fine with a classic Ubuntu 16.04 install. Did someone managed to get wifi work on XPS 13 (8350) with Loki (or Freya) ?

Thanks, Arnaud

  • What kernels are Loki and Freya using? That wifi needs a 4.4 kernel or newer to work
    – Jeremy31
    Commented Jul 4, 2016 at 17:53
  • Freya is 3.1x but Loki is the same kernel as ubuntu 16.04 (4.4) so I'm surprised this doesn't work. Is there something I'm missing ?
    – Arnaud
    Commented Jul 5, 2016 at 7:49

1 Answer 1


After several hours trying to figure this out, switching kernels, drivers, etc. I just found the solution!

sudo apt-get purge bcmwl-kernel-source

This worked for me and now i have Wi-fi :).

  • 1
    Yes it worked for me too ! Many thanks for the magic trick !
    – Arnaud
    Commented Jul 12, 2016 at 7:34
  • For what it's worth, I had to disable secure boot, remove the drivers, and reinstall the drivers. Looks like the part of setup that was supposed to temporarily disable secure boot may have failed. Commented Sep 10, 2016 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.