9

I am using Insync for Gdrive syncronization. I can execute the service but I can not see the Icon anywhere.

Is there any option to see that in the panel or task bar the same as you can see in other distributions?

  • 1
    do you use Loki or Freya? – png2378 Jun 29 '16 at 14:30
  • I'm using Loki and I have this issue myself. – Gabriel Oct 5 '16 at 15:59
4

For me installing sni-qt solve this problem:

sudo apt-get install sni-qt

More information: https://forums.insynchq.com/t/elementary-os-app-icon-in-status-bar-not-showing/1610/2

2

To support legacy icons, you have to install the package wingpanel-indicator-ayatana.

2

Loki doesn't support legacy tray icons. The app has a tray icon, but it won't show up in loki.

My work around is to install trayer, a standalone system tray.

sudo apt-get install trayer

It is very configurable. The command I run to launch it is:

trayer --edge bottom --transparent true --widthtype request --width 10 --expand true --align left --alpha 65

this puts it on the bottom left corner and expands only as far as is needed for the number of icons in the tray. I tried overlaying it on wigpanel. That looks fine, but when you hover over the icons they go away and wingpanel takes the top layer.

There are several ways to run a command like this at boot. One easy method is to install alacarte

sudo apt-get install alacarte

It will be called Main Menu in slingshot. Open it up and create a new item, a new app launcher. just put your trayer launch command in the command section and name it trayer launch or something. Then that will show up as an app in something like gnome tweak and can be set as a startup app.

0

To get autostart for your user it should be in your session.

Goto [System Settings] -- [Applications] -- [Startup] tab -- [+] (in bottom left corner) -- Type in a custom command:

trayer --edge bottom --transparent true --widthtype request --width 10 --expand true --align right --height 32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.