I recently reinstalled Elementary OS (Freya 0.3.2) on my Laptop, but how ever the Networking seems not to work properly.

I've got a "Qualcomm Atheros AR9485 Wireless Network Adapter" which gets detected by the system as lspci shows, but in the Networksettings there isn't even a Wireless-Option.

This article is what I found so far, the Output of lshw -c network is the same as mine. I tried the given solutions, but that doesn't changed anything.

Ethernet works just fine, but I would like to use wifi as before as well. It isn't a problem with the router as the Ethernet-Connection shows and the system is completly newly setup.

So if anybody has an idea how to fix that, I would appreciate the help.

1 Answer 1


I had the same issue, but with a different wireless card. I have a Macbook Air with the Broadcom 4360 wireless card.

I followed the instructions of Ubuntu Community Wiki WifiDocs/Driver/bcm43xx page, and in particular, reinstalling the drivers using the following command solved my problem:

sudo apt-get --reinstall install bcmwl-kernel-source

The same for your wireless card might solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.