0

I wanted prove this linux distro (I heard good things about it), but I'm having this problem with the wifi connection: it simply doesn't work, both during installation and after i have installed the system. More specifically, it finds my home connection, but it can't establish a connection, leaving me offline. I have a USB WIFI ADAPTER, the specific model is the Atlantis Wireless N 300 mps NetFly UP WN (to be clear: http://www.atlantisland.it/pub/prodotti.php?famiglia=1&l1=2&l2=3&articolo=QTAyLVVQLVczMDBO). In the manufacturer's webpage i found out the package with the driver (i believe), but I've not been able to install it (I have some knowledge of linux distros, but I'm not a dragon in this field...).

Can you suggest me some solution??

Oh, I was mforgetting: I don't have the possibility to connect my desktop pc directly to my mode-router directly with the ethernet wire...

Thank you for your attention!

1

That wifi adapter is based on Realtek 8192CU chipset, with known bugs on Ubuntu and derivates.

If you can connect to inet from another pc, you must try to download a driver ported to kernel 3.13 and above, from the next address :

Github.com pvaret

Download the. zip file and copy it to a usb drive to paste in your elementary OS pc.

Once it will be in your pc, extract and rename the folder as "realtek8192cu-fixes". Open panthon-files as root and paste this folder to "/opt". Open Readme.md file inside the folder and follow the instructions.

If you need some aditional help, you can comment this answer.

UPDATE:

According to Readme.md file, I'll try to explain the installation steps:

  • Open a terminal window or simply press Ctrl and T keys.
  • Then you must execute: sudo pantheon-files and put your password when you ask for it. Now you have opened Files as root.
  • Copy rtl8192cu-fixes folder to /opt folder.
  • From /opt , click the right button mouse and choose Open in ... Terminal option. Now you can see a new terminal window prompted to /opt folder.
  • Execute sudo dkms add ./rtl8192cu-fixes.
  • If an unknown command error appears, cause you haven't installed dkms , you can download to another computer the dkms trusty packages from: Ubuntu trusty packages. Copy to elementary OS pc and install it with the command: sudo dpkg -i dkms_2.2.0.3-1.1ubuntu5.14.04.5_all.deb. Try again with sudo dkms add ./rtl8192cu-fixes.
  • Execute sudo dkms install 8192cu/1.10.
  • Execute sudo depmod -a.
  • Once your new driver is installed , remove your old one from boot with sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
  • And finally you must disable power management executing sudo cp ./rtl8192cu-fixes/8192cu-disable-power-management.conf /etc/modprobe.d/.

Reboot your system and try to connect via wifi to your rooter.

  • I tried to do what you have suggested me, but I've encountered these problems (as i previously said, I'm not a dragon in these things): I have downloaded (by another pc) the zip from the site and renamed the extracted folder,but gave that the /opt folder didn't allow me to copy the files in, I searched online and i've found a solution to enable the operation (the command "sudo chmod -R 777 /opt"). From this point all has gone wrong and I haven't been able to solve the problem. – OyD Jun 29 '16 at 14:39
  • HI @OyD. I have edited my answer. I hope it help you. – bitseater Jun 29 '16 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.